After upgrading to version 3 on Linux, Inject nodes disabled

I have the same problem all inject and debug are greyed out.
No start or stop button and no error on the log.
I have tryed to write the timestamp on the dashboard and the value are changing so teh flow is working.

npmupdate as not fixed it

  1. Did you also upgrade to version 3 on windows?
  2. did you try the suggsetions in this thread?
  3. what versions of NR and node.js are you running? (see startup log)
  1. Tryed with upgrade and fresh install on linux
  2. Yes, nothing change
  3. Node-RED version: v3.0.2- Node.js version: v16.16.0

What device and OS are you using?

Also make sure that all installed nodes are at the latest release (look in Manage Palette to check).

I'am using an IOT made by Siemens called IPC227E, is a standard PC with a modified Linux distro installed.
Linux 4.19.217-cip62-rt23+ind3 x64 LE

All nodes are at the latest release.

Are these inject nodes in a regular flow or a subflow?

Do you have the start/stop options in the deploy menu?

Are there any errors in the browser console?

Can you post a copy of the node-red log from launch to running?

Regular flow

No start/stop in the deply menu

No error in the browser console

2b2832f1b89bbf5aa4eb9930f467ea5f1cfb2a401f4035330b7f6715bdfab650-json.log (4.9 KB)

If you open (or add) a Function node are you able to enter code into it and deploy it?

In future please copy/paste logs here etc rather than via a file. Thanks.

What browser are you using, are you able to try a different one?

1 Like

I am able to add any kind of node, open/modify it and deploy everything and it seems to work because i can see data change on dashboard.

Sorry for the log.

I have tryed on Firefox, Brave and Chrome but result is the same

In the startup it shows:
14 Dec 11:12:12 - [s7comm-Error] - Installation of Module net-keepalive failed because we might be on the wrong OS.
can you remove that node and stop/start NR again and see if that does anything

also I see this line:
14 Dec 11:12:12 - [info] HTTP Static : /data/static > /
can you look at your settings.js file and verify what you have for that option

@colin Here is the log

 Custom settings copied.
 Starting NodeRED App...
 > edge-node-red@3.0.2 start
 > node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"
 14 Dec 11:12:09 - [info] 
 Welcome to Node-RED
 14 Dec 11:12:09 - [info] Node-RED version: v3.0.2
 14 Dec 11:12:09 - [info] Node.js  version: v16.16.0
 14 Dec 11:12:09 - [info] Linux 4.19.217-cip62-rt23+ind3 x64 LE
 14 Dec 11:12:09 - [info] Loading palette nodes
 14 Dec 11:12:12 - [s7comm-Error] - Installation of Module net-keepalive failed because we might be on the wrong OS. OS=linux
 14 Dec 11:12:12 - [s7comm-Info] - Debug configuration for logLevelNodeS7:{"debug":0,"silent":true}
 14 Dec 11:12:12 - [s7comm-Info] - Debug configuration for logLevelNodeRED:{"debug":2,"silent":true}
 14 Dec 11:12:12 - [info] Dashboard version 3.2.3 started at /edge-node-red-ui
 14 Dec 11:12:12 - [info] Settings file  : /data/settings.js
 14 Dec 11:12:12 - [info] HTTP Static    : /data/static > /
 14 Dec 11:12:12 - [info] Context store  : 'default' [module=memory]
 14 Dec 11:12:12 - [info] User directory : /data
 14 Dec 11:12:12 - [warn] Projects disabled : editorTheme.projects.enabled=false
 14 Dec 11:12:12 - [info] Flows file     : /data/flows.json
 14 Dec 11:12:12 - [warn] 
 Your flow credentials file is encrypted using a system-generated key.
 If the system-generated key is lost for any reason, your credentials
 file will not be recoverable, you will have to delete it and re-enter
 your credentials.
 You should set your own key using the 'credentialSecret' option in
 your settings file. Node-RED will then re-encrypt your credentials
 file using your chosen key the next time you deploy a change.
 14 Dec 11:12:12 - [warn] Encrypted credentials not found
 14 Dec 11:12:12 - [info] Server now running at
 14 Dec 11:12:12 - [info] Starting flows
 14 Dec 11:12:12 - [info] Started flows

(i wrote a flow to de-clutter it)

Nothing change without s7node

{"log":"Custom settings copied.\n","stream":"stdout","time":"2022-12-14T11:13:04.92113872Z"}
{"log":"Starting NodeRED App...\n","stream":"stdout","time":"2022-12-14T11:13:04.921173405Z"}
{"log":"\u003e edge-node-red@3.0.2 start\n","stream":"stdout","time":"2022-12-14T11:13:05.457974131Z"}
{"log":"\u003e node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS \"--userDir\" \"/data\"\n","stream":"stdout","time":"2022-12-14T11:13:05.457979045Z"}
{"log":"14 Dec 12:13:06 - [info] \n","stream":"stdout","time":"2022-12-14T11:13:06.017416574Z"}
{"log":"Welcome to Node-RED\n","stream":"stdout","time":"2022-12-14T11:13:06.017462413Z"}
{"log":"14 Dec 12:13:06 - [info] Node-RED version: v3.0.2\n","stream":"stdout","time":"2022-12-14T11:13:06.018619344Z"}
{"log":"14 Dec 12:13:06 - [info] Node.js  version: v16.16.0\n","stream":"stdout","time":"2022-12-14T11:13:06.018871026Z"}
{"log":"14 Dec 12:13:06 - [info] Linux 4.19.217-cip62-rt23+ind3 x64 LE\n","stream":"stdout","time":"2022-12-14T11:13:06.019212743Z"}
{"log":"14 Dec 12:13:06 - [info] Loading palette nodes\n","stream":"stdout","time":"2022-12-14T11:13:06.524445345Z"}
{"log":"14 Dec 12:13:09 - [info] Dashboard version 3.2.3 started at /edge-node-red-ui\n","stream":"stdout","time":"2022-12-14T11:13:09.213450329Z"}
{"log":"14 Dec 12:13:09 - [info] Settings file  : /data/settings.js\n","stream":"stdout","time":"2022-12-14T11:13:09.278484136Z"}
{"log":"14 Dec 12:13:09 - [info] HTTP Static    : /data/static \u003e /\n","stream":"stdout","time":"2022-12-14T11:13:09.278890303Z"}
{"log":"14 Dec 12:13:09 - [info] Context store  : 'default' [module=memory]\n","stream":"stdout","time":"2022-12-14T11:13:09.279625057Z"}
{"log":"14 Dec 12:13:09 - [info] User directory : /data\n","stream":"stdout","time":"2022-12-14T11:13:09.280520995Z"}
{"log":"14 Dec 12:13:09 - [warn] Projects disabled : editorTheme.projects.enabled=false\n","stream":"stdout","time":"2022-12-14T11:13:09.280757633Z"}
{"log":"14 Dec 12:13:09 - [info] Flows file     : /data/flows.json\n","stream":"stdout","time":"2022-12-14T11:13:09.281565918Z"}
{"log":"14 Dec 12:13:09 - [info] Server now running at\n","stream":"stdout","time":"2022-12-14T11:13:09.300738875Z"}
{"log":"14 Dec 12:13:09 - [warn] \n","stream":"stdout","time":"2022-12-14T11:13:09.302760764Z"}
{"log":"Your flow credentials file is encrypted using a system-generated key.\n","stream":"stdout","time":"2022-12-14T11:13:09.30279723Z"}
{"log":"If the system-generated key is lost for any reason, your credentials\n","stream":"stdout","time":"2022-12-14T11:13:09.302855065Z"}
{"log":"file will not be recoverable, you will have to delete it and re-enter\n","stream":"stdout","time":"2022-12-14T11:13:09.302858963Z"}
{"log":"your credentials.\n","stream":"stdout","time":"2022-12-14T11:13:09.302863252Z"}
{"log":"You should set your own key using the 'credentialSecret' option in\n","stream":"stdout","time":"2022-12-14T11:13:09.302883706Z"}
{"log":"your settings file. Node-RED will then re-encrypt your credentials\n","stream":"stdout","time":"2022-12-14T11:13:09.302900565Z"}
{"log":"file using your chosen key the next time you deploy a change.\n","stream":"stdout","time":"2022-12-14T11:13:09.302904204Z"}
{"log":"14 Dec 12:13:09 - [info] Starting flows\n","stream":"stdout","time":"2022-12-14T11:13:09.307949603Z"}
{"log":"14 Dec 12:13:09 - [info] Started flows\n","stream":"stdout","time":"2022-12-14T11:13:09.314160174Z"}

for the HTTP i have like this, but i do not know what this does

// When httpAdminRoot is used to move the UI to a different root path, the
    // following property can be used to identify a directory of static content
    // that should be served at http://localhost:1880/.
    httpStatic: '/data/static/',

    // The maximum size of HTTP request that will be accepted by the runtime api.
    // Default: 5mb
    //apiMaxLength: '5mb',

Can you comment out that line in settings.js
// httpStatic: '/data/static/',
and stop/start NR and test

EDIT: never mind, I see that in my startup log too.

@Yusseiin how are you starting Node-red? From a console?
If so you should see the startup messages and should be able to copy then and paste them to a reply instead of getting tehm from a log file.

I see in the log you have provided, at the beginning, Custom settings copied what is this?

Also is the Linux version up to date?

I start the Node-red from a dashboard so i do not have the startup message from the console.
I have call Siemens to get some support and they will conctact me in the afternoon because some OS part are inaccessible to me.
Thanks for now, i will add some information this evening

Hi all, after checking with Siemens it seems that there is a websocket error
But this is not triggering any "error info" in the console or else where.
I can deploy and the flow it is working
This is happening because there is a reverse proxy to reach the node-red page, without this node-red is working fine.

You need to configure the proxy to allow websocket connections.

Did that work before you upgraded?

Yes, before update everything work without configuring anything.

It is odd that it worked if the proxy is blocking websocket access. It seems that it is, however, so the solution is still to make sure it allows the connection.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.