Upgrading to version 3 on windows, Inject nodes disabled

Hi all,
Since upgrading my node-red installation to version 3 my inject nodes all seem to be disabled and I cant enable them.
They do inject if I set them to inject once after deployment.
Any ideas or help would be greatly appreciated

Have you checked the node-red log? Does it have any errors? What version of node.js are you using? I assume you are on Windows 10? Also assuming you restarted node-red and reloaded the Editor browser window after the upgrade?

Also, what browser and version are you using?
Try forcing a cache clear in the browser (using the browser menus, not hot keys).
Are you able to try a different browser?

Also, what do you see in the deploy menu?


I'm on node v14.17.3 Win 10 and restarted/reloaded everything.
Nothing unusual in the logs.
This is my deploy menu.

I'm using chrome and have tried edge as well, same results

Check the developer console in the browser for any errors.

The red Deploy button shows that Node-red thinks you should deploy.
If you click it does it resolve the problem? Does the button remain red?

I have the same problem!

I'm on 3.0.2 running on a raspberry pi. I've not got any pending flow changes like previous posts ask. There's nothing obvious showing in the node-red logs.

I've even tried an incognito window in case it was a Chrome extension, but nothing.

Don;t suppose anyone has any ideas?

Are these inject nodes in a regular flow or a subflow?

Do you have the start/stop options in the deploy menu?

Are there any errors in the browser console?

Can you post a copy of the node-red log from launch to running?

In a regular flow.

My deploy menu has the same options as @Nicky, no start/stop options :thinking:

Will grab the logs :relaxed:

I seem to have accidentally fixed it! I updated all my nodes (npm update within .node-red/node_modules folder, and now they're back and usable!

1 Like

6 posts were split to a new topic: After upgrading to version 3, Inject nodes disabled

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.