Node-Red does not run as a service on a raspberry

Hi, I just upgraded my Node-Red on my Raspberry to the lastet version.

When I try to start it using "./node-red" it starts without any problem.

But when I try to start it as a service using "node-red-start" I am getting the output

"Node-RED is not yet fully installed. Please re-run the install script again manually.
bash <(curl -sL
then retry node-red-start"

I tried to re-install using that script (I have been using it also for the first install), but I still get this message.....

What am I doing wrong here?



Can you post the install log here please /var/log/nodered-install.log
Copy/paste it if possible, using the </> button.
There may be multiple install logs in there, in which case just the last one.

[Edit] Also what to the commands node -v and npm -v show?

node -v shows "v10.21.0"
nmp -v shows "6.14.4"

I have uploaded the install logfile.

nodered-install.log.txt (28.9 KB)

It seems you have been using nvm to manage versions of nodejs. The install script doesn't handle that I don't think.
I believe that if you want to use nvm then you will have to do the node red install manually.

I am not sure what you really mean. I have followed an instruction how to install Node-Red 0.27 (something around that version) and now I have upgraded to that new version. Can you tell me what to do in order to install it properly?
I don't care if I manage versions of nodejs with nvm or something else ....

Which instructions did you follow? If it told you to use nvm then it led you up the garden path.
nvm (Npm Version Manager?) is a tool for managing multiple versions of npm. I don't know how to get rid of it. Perhaps someone else does.

Then re -run the Pi install script

1 Like

Thanks, that solved the problem.

Can you share the link you used to install please? It would be good to provide some feedback to the author, if possible.

I am sorry, but I do not have the link I used for the installation of 0.2x in the past. This is way too long ago.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.