NodeRed is not installed

Hello all,
hope you are doing well and staying safe.
I am working on installation of NodeRed by using nodejs.
I am successfully installed nodejs, But i am facing a problem during installation of NodeRed on Command Window. following is the picture of error.

Can you please suggest me to solve this problem.
Any help ll be appriciated.

That is an unsupported version of node.js and npm. Please use our install instructions and our install script if possible.

You certainly can DIY install it but as you have found - there can be issues.

As Dave alluded to, if you are using raspian (or debian based OS), it is strongly advised to use the install script found here

Thank you sir.
Can you please give me any link related to this.
it ll be a great help for me.

The documentation can be found here

Thank you sir.
I am not using Rasbian. I am using OS of RAK2245 LoRa Gateway.

Where did you download that? I thought that was based on raspbian so the script should still work.

Yes Sir it is based on rasbian.
But when i put a comment for Node-Red on command window,it gives error which is provided above.

Have you tried the pi install script as suggested ? What was the result ?

Yes sir, I am used your install script but got same error.

You haven’t shown us the error it gives when you run the install yet

Hello sir,
Please check the picture attached below.

@rahuldhakate, I fear you are misreading or not understanding what is being asked of you.

@dceejay has already pointed out, that is an unsupported version of node....

And you were asked to provide the output of the install script failure - but again you have posted the output of a direct NPM install.

You did say you had ran the script...

... And were asked for the output - however the screenshot you just posted shows you called NPM directly.

Can you run the script as provided here

and show us the result of that please?


1 Like

Thank you for the help sir.
I got my answer.
appreciating your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.