Node Red Does not Start: Freezes on third info line

Hello!

I have installed Node-red in a server with Windows Server 2012 and when i installed it, everything worked fine. I also installed PM2 to boot it at startup and worked with no problem.
After a few days, when i logged again into the server Node-red didn't start. I went to see the logs on PM2 and it freezed after the third [info] line, the one that lists the Windows version..
Also, if i kill the process in PM2 and i try to start manually in CMD it behaves equally as before.
image
I tried to restart the computer but i am not able to start node red again.
Do you know what could be happening?

Try doing a node-red-stop then node-red -safe (there is a space there) and see if you can get into the backend,

If your windows server account (the one that PM2 runs node-red) has no internet, it will sit for about 3 minutes on that line

try this...

You can do the same by running npm config set update-notifier false

2 Likes

Thank you all for your answers!

I tried first @Steve-Mcl Solution and it worked, but only when i started de Node-red command from Windows CMD. If i used PM2, it didn't do the trick, i think it's because PM2 uses other kind of script.

pm2 start %APPDATA%\npm\node_modules\node-red\red.js

After i tried @dceejay command and now i think that it's working well even with PM2. I'll let you know if all this did the trick.

Thank you!