Node-red is not executing on IBM cloud, on Node-red start kit is not working


#1

Hi,

I'm trying to create a instance of Node-red on IBM Cloud, but it is not get up and not run. The instance became crashed.

Any clue?


#2

Have you checked the application logs?


#3

Yes! There are a lot of "npm ERROR..."


#4

Please find enclosed a screenshot of errors:


#5

I had a similar problem where I made a change (can't remember what) that wreaked havoc. I fixed it by blowing the instance away and starting again. I connected to Cloudant to copy out my flows first and then copied them into the new instance. This was a quick and painless process, so you might want to try it, but it assumes you caused the problem and relies on you backing out the most recent changes.


#6

A screenshot of a random selection of log messages doesn't really help.

You need to get the full log output. The easiest way to do that is to use the command line tool to access the logs. Check the documentation for how to do it - I don't have a link to hand.


#7

Hey @sergiogama, suddenly it worked again... :slight_smile: