Node-red Multiple Projects

Hi, ive been searching for something like this plugin:

But when i installed it doesnt show up the menu for create projects, i dont want to RUN multiple projects i only want to organice flows from different projects what i'm doing wrong?

when i install from console it says bootstrap popper and jquery missing or something like that, please help!

That node hasn’t been updated in over 5 years so I wouldn’t hold out much hope for getting it working.

you are right... but how can i separate my flows in a way like "projects"

Maybe the docs on projects ? Projects : Node-RED

Yes, I already looked for that, I already read it, the issue is that it is not what I need, this works a lot with git and what I want is something like the plugin that I put at the beginning, I hope you can help me, or, if someone tries to install the link I posted at the beginning and can make it work

What is wrong with installing Git?

As I posted before, it hasn't been updated in over 5 years. In addition the author posted this on GitHub

valdepeace commented on May 24, 2017

I have the project stopped because i not had time, i have a lot of work. It was compatible until version 0.14.6, but I will start again from tomorrow for the new version of node-red.

I would say that this node has been abandoned. The only two forks of the project haven't been touched in 5 years eithor.

This basically leaves you with two choices

  1. fix the code yourself
  2. find some other way to do what you want to do.

The project feature works great and you don't have to store your projects on GitHub then can be stored on your local device.

hi, thanks for helping me! there is no problem on using / installing git, i tried to install enabling projects as suggested... BUTit e
if i run from the .node-red directory it doesnt start if i ran the command in a cmd it runs but in the browser stays "stuck" when loading modules it reaches to the last but the ui never loads i.e: Loading Nodes 61/61...
also an alert says failed to load 'node-red / comment'

Do you only get that error with projects enabled? That would be very strange as the projects feature doesn't touch how the palette is loaded in the editor.

Can you check the browser javascript console for any error messages?

How did you install Node-RED? Have you customised or modified the code at all?

The function RED.projects.refresh does exist in a proper build of the code.

as in the site....
normal nothing weird just installed node.js and then npm install --unsafe node-red //or something like that was the command (i repeat is the way that says in the web of node red)

i see other people that have uninstalled everything and installed everything again and it works!

i dont know how to get work the projects in node-red

here is the output on the console when starts:

Welcome to Node-RED

6 Aug 19:37:28 - [info] Node-RED version: v2.0.5
6 Aug 19:37:28 - [info] Node.js version: v12.14.0
6 Aug 19:37:28 - [info] Windows_NT 6.3.9600 x64 LE
6 Aug 19:37:33 - [info] Loading palette nodes
6 Aug 19:37:57 - [info] +-----------------------------------------------------
6 Aug 19:38:28 - [info] | uibuilder initialised:
6 Aug 19:38:28 - [info] | root folder: \Users\T3chn0.node-red\uibuilder
6 Aug 19:38:28 - [info] | version . .: 2.0.7
6 Aug 19:38:28 - [info] | packages . : vue,bootstrap,bootstrap-vue,angular,,jquery
6 Aug 19:38:28 - [info] +-----------------------------------------------------
6 Aug 19:38:30 - [info] Dashboard version 2.19.3 started at /ui
It looks like serialport didn't compile properly. This is a common problem and its fix is well docum
ented here GitHub - serialport/node-serialport: Access serial ports with JavaScript. Linux, OSX and Windows. Welcome your robotic JavaScript overlords. Better yet, program them!
The result of requiring the package is: undefined
6 Aug 19:38:33 - [warn] ------------------------------------------------------
6 Aug 19:38:33 - [warn] [node-red-node-arduino/arduino] Missing serialport dependency
6 Aug 19:38:33 - [warn] ------------------------------------------------------
6 Aug 19:38:33 - [info] Settings file : \Users\T3chn0.node-red\settings.js
6 Aug 19:38:33 - [info] Context store : 'default' [module=memory]
6 Aug 19:38:33 - [info] User directory : \Users\T3chn0.node-red
6 Aug 19:38:33 - [info] Projects directory: C:\Users\T3chn0.node-red\projects
6 Aug 19:38:33 - [warn] No active project : using default flows file
6 Aug 19:38:33 - [warn] Flows file name not set. Generating name using hostname.
6 Aug 19:38:33 - [info] Flows file : \Users\T3chn0.node-red\flows_SR-Jhon.json
6 Aug 19:38:33 - [info] Server now running at
6 Aug 19:38:33 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

6 Aug 19:38:33 - [info] Starting flows
6 Aug 19:38:34 - [info] Started flows
6 Aug 19:38:34 - [info] [mqtt-broker:mosquitto] Connected to broker: mqtt://localhost:1883
6 Aug 19:38:56 - [warn] [ui_base:77badd54.6fe014] C:\Users\T3chn0\node_modules\node-red-dashboard\di
st\js\ not found. Maybe running in dev mode.
6 Aug 19:38:56 - [warn] [ui_base:77badd54.6fe014] C:\Users\T3chn0\node_modules\node-red-dashboard\di
st\js\ not found. Maybe running in dev mode.

You need to fix these.

  1. install build tools
  2. Reinstall Arduino node


Open an administrative CMD prompt (right click cmd, run as administrator)

npm install --global windows-build-tools

This can take quite some time and appear to not doing anything for 30 mins - wait for it to finish.

Then from your .node-red directory, npm install node-red-node-arduino/arduino

This will reinstall the serial port and compile the bindings for your system.

Hi, thanks for your help i will try AND post the results here!

The strange part Is when i remove the project from settings.js file ir works.

If i actívate project again it stuck in loading nodes

The error is happening because your install appears to be missing parts of the projects code in the editor. This is why it hits an error when you enable projects.

The strange thing is the entire editor code is in a single file, red.min.js - it can't just lose bits of it.

This is why I asked how you installed and if you'd been modifying the code.

You may need to reinstall to see if that fixes it.

it takes his time.... after that i ran the first command -->npm install --global windows-build-tools
when i try the second one -->npm install node-red-node-arduino/arduino

it ask me to update .Net framework...
i did it and now...

Ok after executed in admin mode cmd... FINALY it prompts me to acces my git account :slight_smile:
keeps Stuck... :frowning:

if i go to: GitHub - serialport/node-serialport: Access serial ports with JavaScript. Linux, OSX and Windows. Welcome your robotic JavaScript overlords. Better yet, program them!
it doesnt exists.... or is too old

Question: Can i remove uninstall <-- Whatever!!!!
it doesnt matter the serial port doesn work i will fix that later.... but for now is there any solution to get rid of this?

installed no more errors on the serial port i have to add popper.js from -->npm i @popperjs/core
and then --> npm install node-red-node-arduino

now it loads 62 nodes and....Stucks! >:c

I tried everything but finally deleting the folder .node-red solved <-- in this point i just wanted to start from 0.....

the weird part is that i thought that have to reinstall but for some reason just typed node-red in a terminal and... it started anyway and created the .node-red folder again...

now settings.js has changed the project setting was like this:

editorTheme: {
/** The following property can be used to set a custom theme for the editor.
* See GitHub - node-red-contrib-themes/theme-collection: Collection of Node-RED themes published by the Node-RED Contrib Themes team for
* a collection of themes to chose from.
//theme: "",
palette: {
* The following property can be used to order the categories in the editor
* palette. If a node's category is not in the list, the category will get
* added to the end of the palette.
* If not set, the following default order is used:
//categories: ['subflows', 'common', 'function', 'network', 'sequence', 'parser', 'storage'],
projects: {
* To enable the Projects feature, set this value to true /
enabled: true,
workflow: {
* Set the default projects workflow mode.
* - manual - you must manually commit changes
* - auto - changes are automatically committed
* This can be overridden per-user from the 'Git config'
* section of 'User Settings' within the editor
mode: "manual"

i don't know why but it's working now :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.