Node-red-node-email stops working

I use node-red-node-email to check for certain mails in a certain folder.
I login to gmail with my own domain and app password, this works perfect till the moment the node stops.
It also worked without problems till i moved to docker and updated everything a while ago.
No error is shown in the console, i have no other logs at the moment.

When i redeploy the node with the same settings, it gets all the missed mails immediately.

Anybody who has an idea?

If you add a Catch node linked to the email node does it send a message?
Similarly what does a Status node show when it fails?
In both cases configure debug nodes to Show Full Message to see what is there. Name the nodes so you can easily see which is which.

I don't know what you mean link a catch node to the email node, the email node i configured checks for new mails via IMAP protocoll and has 1 output.
I added a catch node that will send me an email when an exception is thrown, i guess that is what you mean.

I have a debug node attached, but no more output is generated when i see the mail node stops working. When i redeploy the specific node, output is generated and picked up by my function node and the attached debug node.

The mail node just stops checking new mails after x time.

We have had occasional reports of this. But not been able to replicate it locally so hard to debug. I can’t think why it would make a difference but have you also tried a repeating inject to trigger the fetch ?

The node only has an output, is there a way to trigger it repeatedly?

By setting the Get Mail option to triggered...
image

Thanks, hadn't noticed that option.
I added extra debugging and the node is now triggered by an inject node.
I also took the mail node out of a subflow.

I had the issue serveral times last days, i'll report here how it goes.

My alarm system sends mails on set, unset, alarm,... i parse the messages and update states in Home Assistant depending on what is happening. Since we turn it on/off every day, i notice when it doesn't do the job.

Same issue since this morning.
It looks like the IMAP Mail node gets stuck in "connecting".
I see the status of the node stays connecting, if i manually inject the trigger, the status stays "connecting".

A "redeploy" (after faking an edit) of only that node resets it and everything is working fine again.
My catch node didn't catch an error.

2020-10-28 07_29_44-Node-RED _ nodered.pixtria.com

1 Like

Just had the same issue again, node stuck in connecting, no more output, no error thrown.

What can i try? Suggestions for deeper debug are welcome.

Little topic bump.... Still have the problem, chances are small that an external error causes the problem.
Anyone else seeing this and/or have a possible sollution or workaround?