Node-RED Projects: using an organization's Github repository with SSH


I am wondering if anyone has tied Node-RED to an organization repo over SSH before, because I am having some trouble. Is it possible? I have setup a Github remote over SSH to a personal repo before without issue.

Here is what I have tried:

I am part of an organization that has a repository with flows.json, credentials.json, package.json

I generated an SSH key through the Node-RED projects settings: ssh-rsa AAAAB3NzaC1yc2EAAA... (etc)

I added the public key to the organization's Github repository as a Deploy key (note: during troubleshooting I have also tried adding it to my personal account's SSH keys)

Now I am trying to clone the project over SSH using the Github projects "New Project" template. This is what I have for each step:

Username: using my personal account username
Email: using my github account email
Project name: using same as the repo (for simplicity)
Git repository url: ssh://[my organization]/[repo name].git
SSH Key: the key I generated shows up so I select it
Passphrase: none for now (when I figure out how this works I can make a new key)

When I try to follow through with this, I get "Authentication failed"

The chance that I am doing something wrong is non-zero (high), but I also realize there may not be support for cloning from organization repos using deploy keys.

I think I fixed my own problem. I may leave this post up for anyone else who runs into similar issues.

If you look at the SSH URL I was trying, I had:
ssh://[my organization]/[repo name].git

That URL is based on the one Github provides when selecting "SSH" as a cloning method.

The issue is the colon : between github and my organization. The proper URL should be:
ssh://[my organization]/[repo name]

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.