Node red too slow on raspberry pi 3b+ after network interface up

I was try project on Raspberry pi 3b+ with dhcp and utp unpluged. It was ok. When eth0 set static ip on pi 3b+ node-red & gui (media,clock etc...) goes slow down. I was turn off nic with ifconfig eth0 down command system return to normal speed.

What is my issue?

Best regards

Are you running any network related tasks?
In a terminal run top and see which, if any, processes are hogging the processor.

What do you mean by node red going slow? Do you mean the browser runs slow? If you run the browser in a PC showing the pi node-red server does it still run slow?

Hi Colin
Thanks for express answer.

The browser have work properly. When i call node-red adress it's comming too late and stay stuck while loading. I saw this delay left on top indicator in node-red workbench window. Node-red dose not have response mouse click immidietly.

And the answers to my other questions?

No more related network task runing on this board. No pressure on cpu and network.
Everything was good until disable the DHCP client daemon. Because not have dhcp server planned topology.

And the other questions? Still two to answer. Running top and running the browser on a PC.

As COlin Says - SSH into the Pi and run top - find out what processes are consistently using CPU time and what the load (top right of the screen) is showing

If the busy processes are network related, then use the tools in this link to isolate what is happening

Are you sure the Pi is secure and you do not have any spyware/crypto mining on there that is looking for an internet connection ?

Can you burn a new SD card with just the PI OS (whichever one you are using) on it and see if it has the same problem when you start networking - if it does then i would suggest you have a physical problem, cabling, switch port, bad ethernet port etc



That is a good point, @muharremsari have you had any ports forwarded from the internet to the Pi without appropriate security? Particularly node-red. Open port 1880 up to the internet and it is very likely that your Pi will be infected with malicious flows.
If so then start again with a fresh Raspbian image.

No internet connection. Pi connected to intranet. I inspect top result. High CPU pressure by chromium.

You still haven't answered one of my original questions, what happens if you run the browser on a PC instead of the pi?

It is showing node-red using a full processor also, so node red is involved in the problem in some way. I suggest you start node-red in safe mode using node-red --safe then disable all the flow tabs and deploy. Check top then and if ok re-enable tabs and deploy till it goes wrong, then you will know which tab the problem is on.
Does it speed up again if you just unplug the ethernet cable?

This is most likely a problem.

My RPIs work happily with NR but as soon as I load FF or chrome, the CPU basically dies.

Though maybe not THE problem, it won't be helping.

My advice: Don't run a browser on the RPI running NR.

Yes speed is up unplug ethernet cable.

You still haven't answered the question you replied to (browser on another pc) nor have you said what happens if you try my suggestion (running with --safe and disabling tabs).

In my case if i don't run chrome on RPI 3b+ and open node on other device browser it works perfectly.
Chrome hog RPI ram.