Node Red very Slow

Hello Everyone
I am having Issues with Node Red.. It appears to be the same issue on at least 6 Raspberry Pi 4B models that I am running Node Red on.
The Issue is the screen and moving Nodes etc is very slow.. It takes up to 5 seconds to drag a node onto the screen. I have an Inject node and a debug node on the screen at present and they are the only two node running on a Raspberry Pi 4 B 4B ram and an Argon One M2 case and a 256 GD western digital green Sata SSD.
Everything was running good but this last week everything seems to have slowed down to the point where it takes 5 to 6 seconds to drag a node onto the page then up to 7 seconds after I hit the timestamp tab for the time stamp to appear on the debug screen.
I have different Raspberry Pi running some with Argon one M2 case some without all have some SSD drive so no flash cards 4 have the western digital 256 GB Sata SSD and 2 have USB 3.0 Plug in SSD drives plugged into the Raspberry Pi as the boot drive.
I have tried working with VNC and plugging a keyboard and mouse into the Raspberry Pi and still same.
I am running all of them in the Headless mode with a 1920 X 1080 screen resolution.
I have one Raspberry Pi running a lot of Nodes for House and Pool control program and one running Inject and Debug node only and all seem to be the same very slow and takes a long time to move nodes on the screen or to do simple Inject.

I am running Bullseye on a couple and Raspian on the rest and all running Node Red Version 3.02 I think this is the latest.
When I click on the Hamburger menu it takes up to 7 seconds for the drop down menu to appear and a further 5 seconds to move the cursor to the task I need like flow then another 4 seconds to have the delete menu appear
I have checked the Task Manager and all are using about 5 to 10% CPU and up to 700 MB of Ram memory so plenty left.
Is there anyone else having the same issues and if so how did you correct the problem?

Just to make sure it is node-red causing the problem:

Put the CPU LOAD graph in the top menu bar and check it.
(I give the graph a green background and make the foreground colour red. Then if it is 100% load, the graph shows all red.)
Is it maxed out?

Open a Terminal (CLI) and stop node-red

cd .node-red

What could be happening is that the flow is locked in some loop and so it is hogging CPU load.

If the load was high and goes to nothing after you stopped node-red, then it is most likely a flow problem as I mentioned.

I won't get ahead of things now.

Hope to hear back soon.

What about the powersupply of your pi. Is it good enough to power the pi and ssd.
If it can't deliver enough power the cpu will throttle down.
Have a look at the red led, it will tell you about the power supply.


Why are you accessing the browser on the PI over VNC.

Use the computer to connect to node-red editor directly instead of VNCing to the PI...


Try that - is it improved?

Another question: Are you running dashboard? Do you have lots of data in charts?

Yeah, I had forgotten about that nasty one.

Been there myself for a long time.

I have tested the CPU Load and checked the loading on the CPU 0,1,2 and 3
O goes up to max of 100% and so does 1 when booting up up the web browser and loading Node Red but drop back to 17% when running on Core 0 Core 1 is at about 5 to 7%.
When I stop Node Red the Cores drop to 2% load
The Memory load is running at 400 to 700 MB of the 4 GB..
I am using the Raspberry Pi power supplies and have not changed these they are the official Raspberry Pi power Supplies I bought from Pi Hut in the UK.

I am using VNC because I am in Nottingham and two of the Pi,s are in London and 2 more in Norfolk.
One some of the Raspberry Pi I have dashboards running but on two that are here in my house I have no dashboards running.

I have tried to connect to the local Raspberry Pi on my network and they now seem to work correctly so I am thinking it is a VNC problem.

I have no other way of connecting to the remote Raspberry Pi other than VNC as they are located at least 100 or more miles from where I am.
I am supposed to install a couple more in Corsica so that makes it even harder to connect without VNC.

If you access other sites from the pi via VNC are they also slow? If so then it is not a node-red issue.

Can you use a VPN instead?

Thank you for all your help the two Raspberry Pi that I have locally are working great and not a problem connecting and the speed is normal when I connect with the IP address not using VNC..
I guess the Issue is with VNC not the Node Red..
I will have to set up connection using some other means to be able to connect remotely to the different Pi that I have installed.
I guess it will be another learning process when I thought I had nothing better to do than make the connection using VNC which was simple until very recently.

Once again thank you very much for all your help everyone

Quite a few folk round here use zerotier as a way to create a simple secure vpn-like network for remote access... and then browse as if they were local. Others tools are available.