Node-RED v2.2.0 appearing despite an apparent upgrade?

Hi there,

Loving this tool so far, but have hit a snag while attempting to update. After running

npm install -g --unsafe-perm node-red@3.0.2

And then running


I am greeted with the old v2.2.0 dashboard. What could be happening here? Any support would be appreciated. I've tried clearing my .node-red folder between upgrades, that doesn't appear to be the issue.

C:\Users\v-kiangregory>npm install -g --unsafe-perm node-red@3.0.2
(node:10736) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to '0' makes TLS connections and HTTPS requests insecure by disabling certificate verification.
(Use `node --trace-warnings ...` to show where the warning was created)
C:\Users\v-kiangregory\AppData\Roaming\npm\node-red -> C:\Users\v-kiangregory\AppData\Roaming\npm\node_modules\node-red\red.js
C:\Users\v-kiangregory\AppData\Roaming\npm\node-red-pi -> C:\Users\v-kiangregory\AppData\Roaming\npm\node_modules\node-red\bin\node-red-pi
+ node-red@3.0.2
updated 1 package in 22.468s

8 May 21:45:56 - [info]

Welcome to Node-RED

8 May 21:45:56 - [info] Node-RED version: v2.2.0
8 May 21:45:56 - [info] Node.js  version: v14.17.2
8 May 21:45:56 - [info] Windows_NT 10.0.17763 x64 LE
8 May 21:46:01 - [info] Loading palette nodes
8 May 21:46:02 - [info] Settings file  : C:\Users\v-kiangregory\.node-red\settings.js
8 May 21:46:02 - [info] Context store  : 'default' [module=memory]
8 May 21:46:02 - [info] User directory : \Users\v-kiangregory\.node-red
8 May 21:46:02 - [warn] Projects disabled : editorTheme.projects.enabled=false
8 May 21:46:02 - [info] Flows file     : \Users\v-kiangregory\.node-red\flows.json
8 May 21:46:02 - [info] Creating new flow file
8 May 21:46:02 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

8 May 21:46:02 - [info] Server now running at
8 May 21:46:02 - [info] Starting flows
8 May 21:46:02 - [info] Started flows

I am not expert but I think there is a path problem.

but in the next bit you put:

C:\Users\v-kiangregory>npm install -g --unsafe-perm node-red@3.0.2

Where is the .node-red part in the path?

I am not a windows person.

Hi there,

Thanks for replying :slight_smile:

C:\Users\USERNAME\ .node-red is where the configuration is located. I have cleared this, and then attempted to upgrade with npm. I am still getting the same v2.2.0 dashboard...

Windows is not my preference either, I use Ubuntu Server for my own Node Red projects. Unfortunately this is for a customer, and Windows is what they deal with.

Try removing node red from the same folder that you updated it (using npm remove). Then see if it still runs. If it does then you need to find where else it is installed. These commands might help

npm list node-red
npm list -g node-red

[Edit] In fact, if you have not already removed it, then go into your .node-red folder and run those two commands

To me the paths are different.

In one it is C:\Users\USESRNAME\.node-red\

In the other is is C:\Username\ only.

Or did I miss something?


C:\Users\v-kiangregory>npm install -g --unsafe-perm node-red@3.0.2


I've tried clearing my .node-red folder between upgrades


When using -g then (on Linux at least) the path is not relevant. I assumed that is the same in Windows. I suspect that the problem here is that there is also a local install of node red.

Well, maybe.

But if we overlook this possibility, I think it is not a good strategy and it can come back and bite us.
Better to be safe than sorry.
(Well, IMO at least)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.