Node-red won't launch

29 Oct 11:50:27 - [info]

Welcome to Node-RED

29 Oct 11:50:27 - [info] Node-RED version: v0.19.4
29 Oct 11:50:27 - [info] Node.js version: v8.12.0
29 Oct 11:50:27 - [info] Windows_NT 10.0.17134 x64 LE
29 Oct 11:50:28 - [info] Loading palette nodes
29 Oct 11:50:29 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
29 Oct 11:50:31 - [info] Dashboard version 2.10.1 started at /ui
29 Oct 11:50:31 - [warn] ------------------------------------------------------
29 Oct 11:50:31 - [warn] [node-red/tail] Not currently supported on Windows.
29 Oct 11:50:31 - [warn] ------------------------------------------------------
29 Oct 11:50:31 - [info] Settings file : C:\Users\username.node-red\settings.js
29 Oct 11:50:31 - [info] Context store : 'default' [module=memory]
29 Oct 11:50:31 - [info] User directory : C:\Users\username.node-red
29 Oct 11:50:31 - [warn] Projects disabled : editorTheme.projects.enabled=false
29 Oct 11:50:31 - [info] Flows file : C:\Users\username.node-red\flows_ISS206837.json
29 Oct 11:50:31 - [info] Creating new flow file
29 Oct 11:50:31 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

29 Oct 11:50:31 - [info] Starting flows
29 Oct 11:50:31 - [info] Started flows
29 Oct 11:50:31 - [error] Uncaught Exception:
29 Oct 11:50:31 - [error] Error: listen EACCES
at Server.setupListenHandle [as _listen2] (net.js:1343:19)
at listenInCluster (net.js:1401:12)
at doListen (net.js:1510:7)
at _combinedTickCallback (internal/process/next_tick.js:142:11)
at process._tickCallback (internal/process/next_tick.js:181:9)

What is this and how do I fix it? I have a demo tomorrow afternoon of Node-RED and it just broke on me this morning. Please help!

Is it possible that another version is running?

I would have to say no. I have uninstalled/reinstalled twice with the same errors each time.

29 Oct 12:20:23 - [error] Uncaught Exception:
29 Oct 12:20:23 - [error] Error: listen EACCES
at Server.setupListenHandle [as _listen2] (net.js:1343:19)
at listenInCluster (net.js:1401:12)
at doListen (net.js:1510:7)
at _combinedTickCallback (internal/process/next_tick.js:142:11)
at process._tickCallback (internal/process/next_tick.js:181:9)

What is the full path to your flows file? Copy your flows file to an known location

Best bet given the demo you have tomorrow is to revert to a backup you have taken.

After you have reverted back, copy your flows file back to where it should be

It appears to have confused your %HOMEPATH% as your settings file should be in

NOT C:\Users\username.node-red\settings.js

the path is C:\users(\settings.js

I had to edit my first entry to show c:\users\username earlier

this is the latest error:
29 Oct 12:41:03 - [info] Starting flows
29 Oct 12:41:03 - [info] Started flows
29 Oct 12:41:03 - [error] Uncaught Exception:
29 Oct 12:41:03 - [error] Error: listen EACCES
at Server.setupListenHandle [as _listen2] (net.js:1343:19)
at listenInCluster (net.js:1401:12)
at doListen (net.js:1510:7)
at _combinedTickCallback (internal/process/next_tick.js:142:11)
at process._tickCallback (internal/process/next_tick.js:181:9)

Post edited.....

If you want to protect your username within the forum please keep the
directory slashes in place!

Node-RED is pointed at the flows file but is then creating a new one.

Easiest given your presentation is to revert to your backup.

@wtrk As your problem is on a different operating system and a different error message, please don't hijack this thread and instead open a new topic

Sadly, I don't have a backup at this time. That's why I uninstalled and re-installed however, I'm not having any luck.

Let me give my machine a quick reboot since it's windows and see if that might help.

that's a negative ghost rider

It helps if you wrap path uri's in single back-ticks to make them easier to read and to make sure your back-slashes don't get swallowed as it then makes it impossible to see whether the path is in error or something else is happening.

It looks like Windows is refusing to create port 1880 on the local machine. Does the user running Node-RED have admin privileges? Try running Node-RED in an elevated cmd or PowerShell shell.

If that doesn't work, also try renaming ~\.node-red and then running Node-RED again (from a std cmd/PS shell) in order to recreate the default setup. You can always put other files back in place later.

Finally, is this running on a corporate PC? Might someone have changed security settings?

@TotallyInformation - thanks for the suggestion. Nither worked. I am the security guy within the company and I know I didn't change anything. From working at home on some flows, to coming into the office, the launch process broke

OK, weird. Not sure you have many options other than to uninstall.

I'd be tempted to uninstall Node-RED, any other global nodes and then uninstall NodeJS. Then go back and carefully reinstall NodeJS from the website. Then follow the instructions in the docs to install Node-RED on Windows. Pay attention to comments about admin vs non-admin rights.

If that still doesn't work, I've some instructions on installing Node-RED locally rather than globally. Not very good instructions at the moment but hopefully you can follow them. Not specifically Windows instructions, they work on any supported platform.

I've not had any issues with Node-RED on Windows for a long time.

As Administrator on the PC in a cmd box - run
Netstat -b

This will tell you what EXE is hogging the 1880 port that Node-red wants.

Alternatively as a short term fix to see if it is just a port issue - change the default port that NR wants to run with - say to 1881 and see if it will start then - maybe also post up your settings.js file


As referenced in this blog my solution for the same problem was:

change the port number in %userprofile%.node-red\settings.js . For example, we can change the default port number to 18800 and then it will work:

The 1881 also don't work for me.
Already uninstall->install, nodered and nodejs (10 and 8)

EDIT: I delete all my Hyper-V network cards and now its working.


Thanks a million!!!
Changed my port in settings.js file from 1880 to 18800 and it worked. Previously tried other ports like 1881 but didn't work.

1 Like

Hi ,
i had the same problem , to fix it , i had to check which service /app is using the port 1880 :
in windows cmd : netstat -aon | findstr '[1880]'
but it showed nothing .
i have recently installed Docker for Windows and i knew it was the source of the problem , after some search i found : node.js - Listening to Port 1880 fails on Windows - Stack Overflow

type this in cmd to see blocked ports by Hyper-V :
netsh int ip show excludedportrange protocol=tcp

to free the ports i did :
net stop winnat
for further details see : windows 10 - Many excludedportranges how to delete - hyper-v is disabled - Super User

This worked for me i am not sure what is running on the port it never showed in netstat.

Welcome to the node-Red forum, and thanks for the post, however this topic is over a year old, and will now be closed.
If you wish to raise an issue, please start a fresh topic.