NodeRed behind Proxy


#1

Hi guys,

i have a proxy issue.
Apt-get works but the npm proxy will not work correctly.
I can not install nodes from manage palette, can´t send mails and http request will also not work.
I tried to config the proxy with "npm config set proxy"
I also tried to edit the node-red startup (/etc/systemd/system/Node-Red.service ) with uncomment the proxy settings and configure my proxy behind a company network.
All my efforts does not succed.
Can someone help me?
Thanks alot for your support.


#2

It sounds like your company's network security is blocking some of those sites and/or ports -- most likely you will have to get them to change their policies for accessing things like the npm repo.

But when you say that http request "does not work", that is strange... unless you are trying to access a restricted web site or non-standard port. What happens if you put that same url into your browser? What hw/os are you using to run node-red? what versions of npm, nodejs, and node-red are installed?


#3

Sounds like it's time to speak to corporate IT.


#4

It have to be a proxy issue from my raspberry or npm proxy. If i test it with my notebook in the same network (static ip and so on), same flow with local version of node red, it works.
Is there one more directory where i have to edit the npm/nodered proxy?
Additional: I write the proxy as a ip like http://192.168.1.1:8000
Is there a syntax error or something like this?


#5

I'm not sure what you mean by "npm proxy" -- if your browser on the RPi can get to the web site, then your command line npm commands should be able to as well. Perhaps you don't have a valid dns server defined, or your default gateway is not right?

If you have ssh access to the RPi, try running the curl command from a shell, with the web site url you are trying to connect to. That should give you some clue where the problem lies... Or as @ukmoose suggested, let your IT group figure out why you cannot get to the internet using npm -- they'll probably spend less time to fix it than I did to write this... :wink:


#6

Thanks for the curl command. It was a syntax error. Now the http request works. About my IT I won't say something :joy:


#7

Circumventing the IT restrictions would be sackable by my employer