Nodered Flow missing but Dashboard visible

Flows - Not present
Dashboard - Present

I did not delete them but it just went missing please give advice what could be the issue.

I would suggest when looking at the edit screen force a refresh.
I think SHIFT REFRESH works.

So HOLD the SHIFT button while you click on the refresh button of the browser.

Welcome to the forum @Xerxes

Please give us lots more information.

  1. What exactly do you mean by missing?
  2. Have you tried rebooting the machine running node-red?
  3. Did you change anything at the time it failed?
  4. What OS/hardware are you running on?
  5. Open a terminal and stop, then restart, node-red. Copy/paste here the output you see in the terminal. When you paste it use the </> button at the top of the forum entry window.
  1. not yet

  2. yes i have deployed 2 more items

  3. RHEL (red hat enterprise linus...)

  4. will try that, need ask permission from my colleague

okayy will try that thank you

What do you get if you search (Ctrl+F) for the missing one?
The tabs in the edit pane are flow tabs, the ones in the right hand pane are dashboard tabs. They are not the same thing, though you may have flow and ui tabs with the same name.

That is a UI tab, not a flow tab.

[Edit] On my laptop now, so easier to type. A Flow tab appears in the editor as a tab and has nodes layed out on it. A ui tab is purely a dashboard display entity. ui nodes can specify that they lie on that tab.
Note that there is a flow tab DRBX0811 and there is also a ui tab of the same name, but there is only a ui tab with the name DRBX0821, or at least if there is you have not shown it in the screenshot.

I noted your point that the dashboard tabs and flow tabs are different, however the issues is that several flow tabs had disappeared (pages on Nodered ui also no longer visible via the navigation panel) but the dashboard tabs remains.

  1. are u aware of how this could have happened (access to editor is restricted, no one could have accidentally deleted)?

  2. then is the DRBX0831 missing/no longer there/hidden?

  3. is there a way to recover it, if it is hidden?

Thank you but i have tried and it does not seem to have worked.

What was the outcome that should have happened?

I have tried to stop and start, from the Nodered editor page there were no changed, flow tabs already deleted cannot be found, dashboard tabs that remained are still visible.

pm2 start /usr/local/lib/nodejs/node-v14.15.5-linux-x64/bin/node-red -- -v
[PM2] Applying action restartProcessId on app [node-red](ids: [ 0 ])
[PM2] node-red
[PM2] Process successfully started
│ id │ name │ namespace │ version │ mode │ pid │ uptime │ ↺ │ status │ cpu │ mem │ user │ watching │
│ 0 │ node-red │ default │ N/A │ fork │ 23617 │ 0s │ 2 │ online │ 0% │ 7.0mb │ root │ disabled │

In the right hand pane of the editor select the i info tab. You should see a list of your flows.
Does it include the missing flows?

In the search results image you pasted earlier there appears to be, at the bottom, a button named DRBX0821. What happens if you click that? It should take you to the flow with that button in.

no it does not

this is what shows up when i click on the i for a missing in Flow tab

What version of Node-RED are you running?

What does it do?

This is the closest I can get to what your screenshot shows, but I get a handle to pull down the individual tab info and show the list of flows behind it.
You don't seem to have that handle though. I guess it's a NR version difference.

@zenofmud @jbudd