Non-http transport requested

#1

Hi,
I am trying to get xml data from a weather web server. When I use this URL in a browser it works fine and I receive the xml data.
URL:https://api.weatherlink.com/v1/StationStatus.xml?user=001D0A00DE6A&pass=DEMO&apiToken=demo0a002bc5272033001d0a002bc527

If I put the same URL into a "http node request" then I just receive "non-http transport requested" error. I looked around about this error but I did not find any description or definition.
Am I doing something wrong?
Any clue?
thank you
JZ

[{"id":"4f7f0495.ab424c","type":"inject","z":"15355a7e.125016","name":"Tick","topic":"","payload":"","payloadType":"date","repeat":"120","crontab":"","once":true,"x":225.99998474121094,"y":254.3333282470703,"wires":[["de26ba05.65fbf8"]]},{"id":"de26ba05.65fbf8","type":"http request","z":"15355a7e.125016","name":"Davis weatherLink","method":"POST","ret":"txt","url":" https://api.weatherlink.com/v1/StationStatus.xml?user=001D0A00DE6A&pass=DEMO&apiToken=demo0a002bc5272033001d0a002bc527","tls":"46469723.30c598","x":410.16665267944336,"y":254.33333587646484,"wires":[["ea945ecb.57d38","646b371b.4f2198"]]},{"id":"ea945ecb.57d38","type":"xml","z":"15355a7e.125016","name":"","attr":"","chr":"","x":587.6666526794434,"y":254.33333587646484,"wires":[["5e607ee.0b0148"]]},{"id":"646b371b.4f2198","type":"debug","z":"15355a7e.125016","name":"","active":true,"console":"false","complete":"false","x":618.5,"y":299,"wires":[]},{"id":"46469723.30c598","type":"tls-config","z":"","name":"","cert":"","key":"","ca":"","certname":"","keyname":"","caname":"","verifyservercert":true}]

0 Likes

#2

I think you probably want GET rather than POST, and don't tick Enable Secure, and take the space off the front of the URL.

0 Likes

#3

Hi Jose,

If it shouldn't work after all the recommendations from Colin, please have a look at my node-red-contrib-http-logger node. This allows you to see which http request is being send by Node-RED. You can then compare that request with the request send by your browser (which you can easily display with the developer tools of your browser)...

Good luck!
Bart

0 Likes

#4

Thank you Colin. (good observer).
In fact the problem was the additional space at the beginning of URL. :slight_smile:
It's working fine. Simple solution !
@Bart
Thank you for the tool you suggested. I tested it, it's quite interesting for debugging and /or understand data interchange between server and client. :+1:

kind regards
JZ

1 Like

#5

You also shouldn't be using post or have the TLS box checked.

0 Likes

#6

Ok Colin, agree.
I will remove the TLS and use GET.
Thanks again
JZ

0 Likes