Not connecting to a usb port

It is the one where you setup the baud rate I want to see. Click on the pen next to the /dev/ttyUSB text to see it.
Also please confirm that if you click on the drop down arrow next to the pen that you only see one entry in the dropdown.

This is the one from the node that is not returning a value. They should be the same as there is only one USB0 in the drop list were you select the port.

There is one set to USB1 for another node in a different flow to connect with a GPS connected to the system.

In your image at the bottom it says 1 node is using this config... I would have expected to see 2 if it being used by both (hence the thrust of Colin's questions)....

As you seem to be sending a command and looking for a response did you try thr serial request node instead of an out and in ? What you are doing should work - but they need to both use the same config.


As you have it, the input node will never pass on anything unless it receives a new line character. As an experiment change it to After a Timeout of, say 100 milliseconds and see if you receive anything.

Is the message you hope to receive in reply to one you have sent? If so then you should be using the Request node, not Out and In.

Dave's comment is important, the fact that it says only one node is using that config, whereas it should be two. You need to investigate that.

I did notice that it only says 1 node. yet in the Flow view it shows both connected.

The way I did the setup was.

Using one of the serial ports I created the connection.

I then connected the other port to the same port in the drop down list.

If memory serves me right it was the inject that got setup first.

I just disconnected the USB inject and reconnected they both show connected.

Now when I go to the edit screen and it now shows two connected.

Same behavior. I can change the frequency but cannot get the frequency returned.

I tried the FA;\r and FA;\n no change.

I have not tried the Serial Request yet.

This is as much a learning of how to use serial request as it is connecting with a device.

I did look at the tool tip for it but thought it was a little more complex to set up. Id did look like though If set up it would be one node used rather than two. My next adventure.

thanks for enfasizing that. My response to him shows details of my steps. Glad your fallowing along.

Have you tried specifying a timeout for input in the serial node?

I thought you said that the commands were getting to the radio ok because you could see they were having an effect.

However, if what you are looking for in the input node is a response to what you send in the output node then you should certainly be using the request node, that is what it is for.

Injecting the FA000105700; changes the frequency of the radio

Injecting the FA; is supposed to return the value of the currently set frequency. There is no returned data from the radio. FA; should return FA000105700 value or whatever the frequency is set at at the moment of the inject of FA;. As per the Yaesu manual.

I have not tried a time out. Not sure how I would do that. Or what it should be set at.

I will replace the serial in with the response note and see what happens. Though if that is required I would wonder what serial in is for.

I just did it an it timed out.


Did what and it timed out? What do you see that tells you it timed out?

injected frequency

frequency changed on rig

Injected FA;

Timeout no longer there rig not returning frequency.

Remove the other serial nodes, have only the serial response node. You have not shown us how you know there is a timeout. Make sure the serial config shows that it is in use by only one node in.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.