Not sure how to deal with httpAdminRoot

Hi folks,

Got an issue today on Github about one of my nodes. The user has uncommented this part of his settings.js file:

httpAdminRoot: '/admin',

And then the images of my node cannot be loaded anymore from his docker container...

So I wanted to reproduce this problem on my Windows 10 portable running Node-RED:

  1. I uncommented that line in my settings.js file

  2. Now as expected I had to add /admin in my browser's address bar to be able to connect to my flow editor.

  3. But my images are still being loaded correctly (even after clearing the browser cache):

  4. The Network tab indee shows that the images are loaded from the new extended url:

I had expected this to fail (similar to his Docker setup), since my endpoint is not using RED.settings.httpAdminRoot in any way (explicit)...

Can somebody please enlighten me about what I am doing wrong?


Not entirely sure what's happening - can't see anything obviously wrong.

One thing you could consider is to remove the needsPermission middleware from that route. - Given the route just serves static images and no actual user/flow data you could legitimately do that - and it should solve the 401 error.

Thanks Nick!
I have asked him whether that solves his problem. Fingers crossed...

It was indeed solved by removing the permission part. Thanks for the tip!!!

This fix for the tank-volume node is now published in the pallette as version 1.0.1:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.