NR not show flow


#1

Hi!

My system, after restart, not show flow.

The dashboart is show normal.

Change the use port but the error show:
Welcome to Node-RED

10 Oct 06:36:26 - [info] Node-RED version: v0.19.1
10 Oct 06:36:26 - [info] Node.js version: v10.8.0
10 Oct 06:36:26 - [info] Linux 4.15.0-33-generic x64 LE
10 Oct 06:36:27 - [info] Loading palette nodes
10 Oct 06:36:27 - [info] RedBot version: 0.14.3 (node-red-contrib-chatbot)
node-telegram-bot-api deprecated Automatic enabling of cancellation of promises is deprecated.
In the future, you will have to enable it yourself.
See https://github.com/yagop/node-telegram-bot-api/issues/319. internal/modules/cjs/loader.js:689:30
10 Oct 06:36:29 - [info] Dashboard version 2.9.6 started at /ui
10 Oct 06:36:29 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
10 Oct 06:36:29 - [warn] rpi-gpio : Cannot find Pi RPi.GPIO python library
10 Oct 06:36:30 - [info] Settings file : /home/pi/.node-red/settings.js
10 Oct 06:36:30 - [info] Context store : 'default' [module=memory]
10 Oct 06:36:30 - [info] User directory : /home/pi/.node-red
10 Oct 06:36:30 - [warn] Projects disabled : editorTheme.projects.enabled=false
10 Oct 06:36:30 - [info] Flows file : /home/pi/.node-red/flows_home-pc.json
10 Oct 06:36:30 - [error] Unable to listen on https://127.0.0.1:2410/
10 Oct 06:36:30 - [error] Error: port in use


#2

I have already set up ports 8080, 1880, 81, 8080 and continue the same way.

Apparently everything in the red node is normal only that does not show the flows.


#3

Youmight want to try using node.js v8.x - see https://nodered.org/docs/getting-started/installation
Before you can install Node-RED, you must have a working install of Node.js. We recommend the use of Node.js **LTS 8.x** .


#4

Hi @dedynobre,

Do you know what is running on port 2410?


#5

Not really.
He was running on port 8080 a while ago. Yesterday I restarted the raspberry pi he did not rotate anymore.
I tried several other doors to see if it worked again but it did not work.
The interesting thing is that the dashboard works with the port I set up.

Could it be some misconfigured flow?


#6

There was a Home Assistant component which when looking at the log was in trouble.
I removed it.
But even then, he did not roll anymore.
Everything is running normal just does not appear the flow.


#7

What url are you using for the dashboard and what url for the editor?
What do you see in the browser when you attempt to get the flow?
Look in the browser console when you try to load the editor and see what it shows.
Have you downgraded node.js as suggested?


#8

Hi @dedynobre

Is that the end of the log output on startup?

For a 'normal' startup, you'd expect to see:

10 Oct 06:44:02 - [info] Server now running at http://127.0.0.1:1880/

The fact you don't have that means something has hung on startup.

You need to track down what is using/trying to use port 2410. The first step is figure out if its a separate process. There are various ways to do this - https://unix.stackexchange.com/questions/106561/finding-the-pid-of-the-process-using-a-specific-port

Don't worry about your version of node - whilst we recommend Node 8 as the current LTS version, Node 10 is stable and I'm not aware of any issues with it.


#9

But the dashboard is said to be working. Is that possible?


#10

Dashboard is working normally.
I believe it is not something specific with port 2410 because since when I started with the NR was using port 8080.
Port 2410 was the last one I tested and collected the data to send here.
But before I tried other ports as I listed above.

I was thinking it might be something with some specific flow, could it?

The last one I used was the home assistant (which I already removed) and the mysql that works.

Everything that is in the NR is working I just can not do anything.

I know this because the NR sends data to a cloud database that is sending normal and the telegram is also working.


#11

You haven't answered these questions. Also why are you not using the standard port?
Also post the complete startup log this time.


#12

Please edit your settings file, find the logging entry and change the level to trace. Then restart Node-RED and share the log with us.

That will give us a bit more information about what the runtime is doing and where, if anywhere, it's getting stuck.


#13

Dashboard: https://localhost:2410/ui
Flow: https://localhost:2410

In browser not show information only in menu right.


#14

The default port not is working.


#15

Hi,

I remove the nodes unused and after restart node red is working.


#16

Any types in particular that you removed ? Maybe there is a broken one that needs to be reported.


#17

I removed the following components:

node-red-contrib-kodi

node-red-contrib-machine-learning

node-red-contrib-watson-machine-learning


#18

Welcome to Node-RED

11 Oct 20:45:15 - [info] Node-RED version: v0.19.1
11 Oct 20:45:15 - [info] Node.js version: v10.8.0
11 Oct 20:45:15 - [info] Linux 4.15.0-33-generic x64 LE
11 Oct 20:45:15 - [info] Loading palette nodes
11 Oct 20:45:17 - [info] RedBot version: 0.14.3 (node-red-contrib-chatbot)
node-telegram-bot-api deprecated Automatic enabling of cancellation of promises is deprecated.
In the future, you will have to enable it yourself.
See https://github.com/yagop/node-telegram-bot-api/issues/319. internal/modules/cjs/loader.js:689:30
11 Oct 20:45:20 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
11 Oct 20:45:20 - [warn] rpi-gpio : Cannot find Pi RPi.GPIO python library
11 Oct 20:45:21 - [info] Dashboard version 2.9.6 started at /ui
11 Oct 20:45:23 - [info] Settings file : /home/pi/.node-red/settings.js
11 Oct 20:45:23 - [info] Context store : 'default' [module=memory]
11 Oct 20:45:23 - [info] User directory : /home/pi/.node-red
11 Oct 20:45:23 - [warn] Projects disabled : editorTheme.projects.enabled=false
11 Oct 20:45:23 - [info] Flows file : /home/pi/.node-red/flows_home-pc.json
11 Oct 20:45:23 - [error] Unable to listen on https://127.0.0.1:1880/
11 Oct 20:45:23 - [error] Error: port in use


#19

To be continued


#20

pi@home-pc:~/.node-red$ sudo fuser -v 1880/tcp
[sudo] senha para pi:
USUÁRIO PID ACESSO COMANDO
1880/tcp: pi 22012 F.... node-red