NRF24 - WiFi Problem on raspberry pi

Hi! A few days ago, i tried to use NRF24 node.
The thing is that there's an error ocurring and the module doesn't load up (i can see this in node-red log).
But something strange is happening: when this error occurs, Raspberry Pi's wifi crashes.
I uninstalled the NRF24 node and everything came back to normal.
Does anyone know what might be causing this issue?

Thanks in advance.

It’s always worth staying the full node name as well as which versions of node-red and node is you are using.

Also if there is an error message what did it say?

How did you. install the node? Have you followed any instructions in the nodes readme?

Also how do you know the wifi is crashing?

Even more also did you see this when you checked for issues on the github page of what I presume is the node you are using. It talks about NR hanging, though that is not the same as the wifi crashing of course.

Hi, i'm sorry, i'm a little new to this.
I've read the doc from and installed prerequisites following this
Node-Red version should be the last one stable 'cause i've updated it and upgraded it yesterday.
The error i was getting, simply said NRF24 working:false and NRF24L01(+): false.

Something i noticed is that i cant find the config to choose whether my module is the common version or the + version (i have the + version).

Colin, I read about it but dismissed it because it's not the same problem.
For two days i was struggling to find the cause of wifi losing connectivity (just in raspberry pi, my phone worked well) few seconds after boot.
I made a fresh raspbian install and wifi worked well, when i reconfigured node red with my nodes, wifi starts to fail again.
The symptoms are: wifi with no conectivity to the network after a minute of booting in spite of saying its connected. If i disable wifi and turn it back on it doesn't show any AP's. On reboot wifi picks again the AP's but after a minute the same happens.

  1. does the reboot of th Pi restart NR automatically?
  2. if so, what happens if you disable the NFR24 node? Do you still loose WiFi after a reboot?

If you are sure you have followed the install instructions, then I would suggest opening a new issue on the nodes github page

Zenofmud: 1. Yes.
2. No. After I uninstalled the nRF24 node and rebooted WiFi worked properly.

Ukmoose: I will try installing everything again in case I've missed something out. If I get the same problem I will start an issue on GitHub.

If you disable the node and tehre is no problem it would indicate that the node is causing the problem and I would report it to the node author.