Offcial AWS ElasticBeansTalk Tutorial not working

please help.
I am unable to deploy node-red using official docs on : Running on Amazon Web Services : Node-RED
Going through AWS EBT logs I found this errors:

node-red -s ./settings.js
Error loading settings file: /var/app/current/settings.js

I think it has to do with this part of package.json from tutorial

scripts": {
        "start": "./node_modules/.bin/node-red -s ./settings.js"

Also being answered on slack -

Still does not work. In the end I gave up choosing my own region because of AWS S3 bucket creation error present in logs. Now I tried using exact tutorial, no changes; Left Region EU WEST 1; Only change I did was to add Node version to 14.0.0 in package.json. Everything worked deployment wise but now I have a new error. This time in the AWS EBT hosted environment in node-red itself. When logging in I have a pop-up error that doesn't have a button to close it: notification.warnings.undefined
And Deploy button is disabled.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.