Omxplayer - "Error: not ready yet"


I'm installed omxplayer on a Pi3 and have installed the omxplayer node with the aim of playing and stopping an mp3 file as part of a flow. From the command line I can play an mp3 using:

omxplayer -o alsa filename.mp3

However when I attempt to use the node to play the same file I get an debug error: "Error: not ready yet". My inject node has a payload of 'playpause' as per the docs for the node. The node audio output is set to alsa as I'm using an I2s amp and speaker...

Has anyone got any ideas of how to debug this error or has fixed it before?

That node hasn’t been updated in almost two and a half years....

I'm getting the same error, on Node Red boot - for the first time with this project that I've been working on for weeks). Sound is also intermittent! Since this is the native video payer for node red and I've found it to be unreliable, is there an alternative that I'm missing that may work in place of it? Workarounds that are node red based?

Well the node hasn't been updated in over 3 1/2 years...

maybe this thread will help [beta testing] nodes for live streaming mp4