OPCUA Client node always on statuts "Connecting"

I have a simple flow in order to read values on a OPCUA serveur on a PLC:

image

I first test the OPCUA value with UAExpert and it works well:

it works with no security&certificate and anonymous.

Then i try to test it in node-red with the same configuration values:

image
image
image

But when i inject i have nothing in return, no error messages, just the status of OPCUA client in "Connecting"... I try with other values, that's the same. I access well the PLC because i tested it with a classic S7 node.

Some ideas ? Thanks in advance !

I have the same issue. I am able to see that endpoint with the same settings in a test client but my UAClient node remains in connecting like yours. Did you happen to find a solution?

No solution found yet :confused:but with the same flow on another PC (the other is on a server) it works so it means that's a network filter or access issue. (but i can ping the IP en both cases...)

I also tried the same using a different PC as well as a different PLC and still have the problem.

Same issue, I can see the tags with a free OPC client using "none/none" for security policy but my OPC node remains in connecting state. If you see the debug node there is an error, I will post mine later today.

I have been trying with a Beckhoff Twincat3 OPC Server and also a Siemens S7-1500 OPC server. No luck.

I have the impression that it is a widespread problem with the OPC_UA node, I also tried installing certificates on the server, setting security policies with user and password, without obtaining positive results.
I would investigate the "local own certificate is not used" system message.

1 Like