Palette manager issue - looks like can't reach internet

Guys,
the situation is as follows: finally i have a time to play with NodeREd. I hooked my setup which is:

  • RB Pi4 4GB running on SSD
  • Pi is running IoTstack and all is in dockers
  • Pi is connected to Tenda router with ethernet cable
  • Tenda router receives internet with ethernet cable from my laptop (Ugreen usb3.0-ethernet adapter)
  • my laptop taks internet over Wi-Fi is sharing it with Tenda router via Ugreen adapter
  • when i connect to Tenda router adming page i can see the router has access to the internet so all the devices connected to Tenda router have access to the internet as well. Including RB Pi4

I'm accessing my RB Pi remotely over the network via ethernet cable (laptops ethernet socket connected with calbe to one of the Tenda router sockets). So opening Node Red, it's working, i can see data incoming via MQTT from my esp8266 device, Grafana trends are ok, updating. Looks nice. Then i wanted to install the following node:
node-red-contrib-telegrambot
using Pallette Manager. Ane here i'm stuck. This is the log:

-----------------------------------------------------------
2022-09-10T12:13:00.632Z Install : node-red-contrib-telegrambot 14.1.0

2022-09-10T12:13:26.877Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production node-red-contrib-telegrambot@14.1.0

-----------------------------------------------------------
2022-09-10T12:15:04.872Z Install : node-red-contrib-battery 1.0.1

2022-09-10T12:21:12.061Z [err] npm ERR! code ETIMEDOUT
2022-09-10T12:21:12.061Z [err] npm ERR! errno ETIMEDOUT
2022-09-10T12:21:12.061Z [err] npm ERR! network request to https://registry.npmjs.org/node-red-contrib-telegrambot failed, reason: connect ETIMEDOUT 104.16.22.35:443
2022-09-10T12:21:12.061Z [err] npm ERR!
2022-09-10T12:21:12.062Z [err]  network This is a problem related to network connectivity.
2022-09-10T12:21:12.062Z [err] npm ERR! network In most cases you are behind a proxy or have bad network settings.
2022-09-10T12:21:12.062Z [err] npm ERR!
2022-09-10T12:21:12.062Z [err]  network 
2022-09-10T12:21:12.062Z [err] npm 
2022-09-10T12:21:12.062Z [err] ERR! network
2022-09-10T12:21:12.062Z [err]  If you are behind a proxy, please make sure that the
2022-09-10T12:21:12.062Z [err] npm 
2022-09-10T12:21:12.062Z [err] ERR! network
2022-09-10T12:21:12.062Z [err]  'proxy' config is set properly.  See: 'npm help config'
2022-09-10T12:21:12.076Z [err] 
2022-09-10T12:21:12.077Z [err] npm ERR!
2022-09-10T12:21:12.077Z [err]  A complete log of this run can be found in:
2022-09-10T12:21:12.077Z [err] npm 
2022-09-10T12:21:12.077Z [err] ERR!     /data/.npm/_logs/2022-09-10T12_21_12_065Z-debug.log
2022-09-10T12:21:12.112Z rc=1

-----------------------------------------------------------

Tried to install another node, the same result. How can i check if my RB has internet connection and if my NodeRed has it as well?
Thank you!

can you ping 8.8.8.8 from the command line where node-red runs?

not sure if i understand "from the command line where node-red runs". Which command line is it? I've connected via Putty to my RB Pi and from there i've checked all the connections:
I can see eth0 has Ip address assigned and it matches info i can see on Tenda router adming page. Additionally, to be fully sure Tenda is sharing internet, i've connected TV to Tenda with ethernet cable and TV is browsing youtube with no problems.

If node red is running in a docker container then you need to open a terminal within that container and check the ping. Just because the Pi has access does not mean that it is accessible from within the container.

Edit, have you ever been able to install nodes in that system?

Is Nore-red running i a docker container?

If yes, connect to the container and ping 8.8.8.8 from INSIDE it. If you can ping 8.8.8.8 (which is googles DNS) then your container CAN access the internet and Node-RED is the problem. However, in pretty much every case I've seen - the issue is your docker setup or the network settings of your docker env / virtual networking / host device. Never node-red.

As this is not a docker forum & most folk either run node-red outside of docker (or know how docker works), I would suggest you head out to the internet or docker forum to understand how to check and setup the virtual networks.

I think i've managed to work it last year. But then i moved to the vessel and then had no access to internet. Here:

i got help from Bart so i could install SSVG editor with no access to internet. At that time company IT policy stopped me from accessing internet onboard. Now i'm at the hotel onshore.

Any way: now i've opened Portainer and opened nodered terminal and then used
"ping 8.8.8.8". Nothing happened:/
port1
When i broke the command the info is 100% packet loss.

So you need to give the container access to the internet. You will need to lookup how to do that.