Possible Bug - Changing text in Function does not save

I went into function and changed the text (between quotes). It did not recognize there was a change and did not save. I can reproduce the issue. To get it to save I just inserted a blank line between code.

Please tell us what version of Node-RED you are using. Also, what browser are you are using?

Lastly, a video or a step by step on how you make this happen would help.


v3.1.0. I keep Node-RED up-to-date.


I changed the following text


When I clicked done it did allow me to Deploy. I went back in and it was not changed. I tried again and it was a no go. I pressed enter to add a line and that worked.


Please state your UA/OS that is opening up the editor (i.e Chrome on Windows) - info that is helpful is below

I cannot replicate this.

OS : OSX Sonoma (14)
UA : Safari Version 17.0

Node RED : 3.1 (bare-metal)
Node : v16.15.1

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.