Problems with the function node in 0.20.2


#1

Hi is there anybody else that got problems with the function node in version 0.20.2
the code text is unreadable after upgrade?


Node-RED 0.20.0 Released
#2

Yes. Got the same problem. Text trucated (line over line).


#3

@arlklauss Hi Antonio, welcome to the forum.

A couple of us have the same problem since v0.20.0. Please answer the following

  1. what platform and OS (with OS version)
  2. what version of node.js (you can get that from the NR log or by entering node -v in a terminal
  3. In your browser, display the JavaScript Console and then open the function node. copy and paste any errors you receive.

#4

Hi i'm using OS 10.x node.js 10.15.1


#5

Hello

  • Using ubuntu 16.04lts (kernel 4.4.0-59-generic), x86_64
  • node v. 8.11.4
  • chrome v.73

That's what I've got from chrome dev console:

Hope that helps.


#6

Ops... wrong image ... sorry
image


#7

Andreas - take a look at the post arlklauss did and you will see what the JavaScript console looks like - that is what I want to see.

If you are using Safari, you might need to go to Safari's preferences -> Advanced and at the bottom and check the Show Develop menu in menu bar to use the JavaScript Console


#8

This really is an unusual bug. I considered it might be down to the version of nodejs on my Pi but it wasn't that and it's also independent of browser type. I can get rid of it by returning to 0.19.6 after every test with 0.20.x.


#9

I've got two mac mini same version of the OS same version of node.js. One never had node-red installed until today. I installed NR and that mac has no problem, the other one has the issue go figure....


#10

I've got several types of Pi with different nodejs versions and they all work fine. It's just this one and now I've lost my Arduino node as a result of my investigation into this.Oh well never mind, didn't want to have a weekend anyway LOL


#11

@knolleary @dceejay I have a BIG lead onthe problem!!!

Earlier today I loaded NR on another mac that had never had NR on it and the problem wasn't happening. Just now I began thinking to myself "What is different?" and it hit me, the contents of the .node-red folder. So I backed up my .node-red folder and emptied the entire folder and started NR The problem is gone!

So it must be a node I have installed or something in the settings file. I'll start digging into that.

UPDATE - ok it is node I have installed! now to track it down (time to remove half the nodes!)


#12

I was beginning to wonder if that might be the case too. Well done on following up your hunch! I'll do a fresh install and do that as well.


#13

Ok in my case the node causing the problem is node-red-contrib-python3-function
If I add that folder into .node-red/node_modules the problem occurs. If I remove it, the problem is gone.

I wonder if there are a couple contrib nodes that might cause the problem???


#14

Great work @zenofmud - installing that node breaks it for me as well.

Now just a simple matter of figuring out why it breaks things....


#15

If you have this problem and don't have node-red-contrib-python3-function installed it may be some other node. Here is what I did to track down the culprit

  1. navagate to your .node-red/node_modules
  2. move all the node-red-contrib-xxxxxx folders to another directory
  3. restart NR and see if the problem is gone.
    If it is,
  4. stop node-red
  5. move a couple of the nodes back in
  6. restart NR and see if you have the problem
  • NO - go to (4)
  • YES it's one of the nodes you moved out - add them back one at a time till you find the bugger!

#16

Now just a simple matter of figuring out why it breaks things....

I leave that to you bright guys, I just figure out what is wrong :stuck_out_tongue_winking_eye:


#17

I had that one installed, it's now being removed. Thanks for your hard work!
Yes, that fixed it :slight_smile:


#18

So that is where the cdnjs link was coming from https://github.com/dejanrizvan/node-red-contrib-python3-function/blob/2456a10c429a5cdd8c9396e7e941e0ca59661cb4/lib/python3-function.html#L1


#19

Thank you for the help problem solved :slight_smile:


#20

@anderdk were you also using node-red-contrib-python3-function?