Can't change code in a function node

Hi,
I have problem with Node-red and function nodes.
Can’t change/write code in a function node.
Nothing happens if I try to type anything in the code section.
Almost as the code is write protected!

Picture from old function node that I want to change.

Have tried to reboot the system but it doesn’t change anything.
And it’s the same if I start with a new function node and try to add code, nothing happens, can’t write any code.
Anybody else that have had the same problem?

Hi,
Try a other browser, flush the browser cache.
If still not working have a look at this topic, not exactly the same problem but maybe it helps you in the right direction.

I have now tried another browser with the same outcome :sleepy:

  1. what vesion of Node-red and node.js? (see the node-red startup log to get this)
  2. are you runing Docker or HomeAssistant?
  3. what device and OS are you running NR on?

Hi,
I'm running
image

How do I check the node.js version?

I'm running HAOS (2022.11.5) on a Nexcom, NISE 3600E computer

These are the node I have installed in Node-red

So, this is an HA problem not a node-red one. Probably better to ask in the HA forum.

1 Like

@TotallyInformation I don't understand how can it be a HA problem?
The only thing I have problem with is the function nodes in Node-red, no problem with HA

Your node-red is a HA plugin so they have edited it for HA use.

Have you searched the forum as there are some topics about this

The problem is how HA calls node-red or some security it is applying. We have never seen - to the best of my knowledge - a problem like this when running Node-RED directly. (E1cid clearly has a much better memory than me! :slight_smile:). HA is a complex product - so complex, the recommended deployment approach is to replace your entire operating system with theirs! Node-RED is itself pretty complex but installation and configuration is simple.

As @E1cid states, this is a known problem caused by "bad nodes" you have installed.

See this thread for which nodes cause this issue...

I think I solved the problem. Updated all nodes and the problem with not being able to change/add code in a function nodes seems to be gone. :grinning: