Problem with http node and Axis camera

i use an AXIS 207 Camear.
I have created a node with this request in a GET :slight_smile:
When I run this node once, it works, I can access to the image, and for example, I can save it in a file.
This is true for some times (about 10)
10 is the max number of client that can be connected on the AXIS web server.

What is strange is that the AXIS camera seems to not close the previous thread. so, after only some few access from nodered to the calera, the max number of theads to access the image if reached.
This camera is queir old, and even with the most recent firmware, the problem is still there, and Axis doesn't give me any good idea to fix my problem.

I know that it exist an exec node wich doesn't close after the command has been sent, I use it for a ping test, for example. The PID is still the same.
Doesn it exist a similar node for http get request so that the request continues to use the previous thread?

What are you trying to accomplish ? Camera delivers streaming video with an option for stills.

So you can capture 10 snapshot images from your camera via httprequest node. What is the delay between those http requests? When I try to capture images too rapidly from my old Panasonic IP cameras, the internal webserver also doesn't get an opportunity to end a request before the next request arrives. So it indeed starts using new threads until it completely hangs... If that is the case you should experiment with a delay between the requests.

1 Like

Finally, it seems that for an unkown reason, my camera did not make any image available
With an other camera, same device, same FW, it works fine