Problem with node-red-node-serialport. No debug message

I was working with a serialport node today and have a weird problem.
The serial port is recognized in the editor and is connected.
I have a serial to TTL converter with short circuit TX to RT pins.
When I send a debug message I do not get it back to serial in.
TX and RX LEDs light up on the converter.
Also the converter works correctly with RealTerm.
I tried uninstalling and installing serialnode, the situation is the same.
Serialnode is 0.10.0.
Node-RED is 1.0.2 on Windows10.
node.js is v12.13.0

What else could I try?


I made a program in Arduino that sends "Ping" and then "Pong" every 1000mS to a serial.
In the meantime, it waits for serial input and, if any, send it to a serial.
"Ping" and "Pong" are printed normally and the input data does not (in Node-RED).
Everything is fine with the Arduino serial monitor.
I also tried on LInux, on the new Node-RED installation, the situation is the same.
Is anyone interested in how his serial out behaves?
Thx for any help!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.