Problems installing nodered dashboard or any other plugins

Hello. I am new to nodered and I tried to install the nodered dashboard. The following message appears:
npm ERR! request to failedIt wont let me update any plugins either. Please help me with this.

You may need to expand on what you did when trying to install the dashboard.

Was it from the GUI or from a CLI? (Terminal)

This is usually a transient problem with your Internet connection or DNS. You would have problems with any npm install from the public registry.

It will usually clear after a short while.

It was from a GUI

Hello and thank you but it has been 3 days and it won't work.

from the command line can you



1 Like

Yes I can

from the same command line, please do something like the following:

mkdir test
cd test
npm install aaa

and report the results.

Thank you for your suggestions.

mkdir test - nothing happened

cd test - nothing happened

npm install aaa - 'npm' is not recognized as an internal or external command, operable program or batch file.

Are you running these tests from the same machine that is running Node-RED (I do not mean where you are running the Node-RED editor in a browser, I mean where the Node-RED backend is running)

I ask because npm has to be installed for Node-RED to have been installed in the first place.

Yes, It is the same machine. I've just ran the following on cmd

npm install -g -unsafe-perm node-red

Are you saying that you didn't see any output and you didn't get anything like this:


Please share with us the output you see.

Previously no but after I installed npm install -g -unsafe-perm node- red

I can now see the same message like you did in the above pic

added 1 package, and audited 2 packages in 1s

found 0 vulnerabilities

You still don't seem to be telling us what is expected and you haven't shared any output.

This is what you would see (I've installed node-red locally but you should see similar):


I will ask one more time for you to please share with us some actual output.

I am confused. Like I said I did not know much about the interfaces.

Right, so now we are getting somewhere. We can see that you are running on Windows and that you do have npm and therefore also Node.js installed.

Now please run node --version and share the output. The version should be at least v12 but v16.x.x would be better.

I appreciate your patience.

Excellent, now we know that you don't need to install another dependency because the Windows version of node.js v16 includes something called the "build tools".

Now, if you successfully installed node-red earlier, you should be able to start it with node-red-start (I think that is the command, I don't actually use it so I don't always remember). It should start to throw out a bunch of information include a URL which you should open in your browser.

PS: Just off for dinner so might not be around for an hour. Maybe someone else will pick this up otherwise I will be back later after family time.

Thank you very much. Meanwhile yes I will check that out.

I'm sorry I was looking at the wrong interface. The message it gave me when I tried to run the above code on the cmd of my actual device is
registrynpmjsorg Host name lookup failure