Problems with node-red-contrib-smartlifeair

Having seen a notification on twitter and a post on another thread from @razorRun I've tried getting this to work with my tuya rgb light bulb

I can get the smartlife app to control my bulb and I've registered myself on the smartlife website but the bulb doesn't show up in the node config


I've tried switching on/off /restarting NR /twirling round 3 times but nothing shows up

has anyone tried it and got it working?

Are you using “Smartlife Air” app ? If not grab it from link in read me.
Let me know how it goes?

Yes - I can fully control the bulb from the smartlife app on my android phone

It's not the smartlife app, It's Smartlife Air by, Goto the link and click the 3rd button "Download Smartlife Air App" in the list.

This is what I have installed on my phone

[edit I can see that there is a Smart Life app as well so I see why you were making sure I was using the right one :slight_smile: ]

Yep, Thats the correct app.

Have you created an account under and added your SmartLife air credentials?

And After enrolling and Operating the device from the app at-least once click save and refresh there. You should see the device list in the browser


Done all that

Also, checked device firmware is the latest (1.5.0)

it should look like this


Well I'm not seeing any devices at the bottom below the Set button :frowning:

I was having a a look at your account, looks like we are not seeing any devices under the credentials. Give me few mins

1 Like

Ah ha! Found the issue, Since you are based in EU it's using our EU db and this node is looking at US DB. I will apply a patch for this later. But for the time bean can you create a new account in mobile app and choose the country as New Zealand ?

setting up using alternative email but going out for a few hours so back later :slight_smile:
Thanks for the prompt support :slight_smile:

:ok_hand: let me know how it goes

Working :slight_smile:

I always wanted to live in New Zealand :slight_smile:

1 Like

Is not everything using the TUYA API under the hood? At one point I had 4 different apps on my phone, because I had 4 different smart plug vendors... until I got the TUYA generic app, and surprise, that one app can see every smart device i have... regardless of the vendor?

OT but I spent over 5 months there in 1990 - had a fantastic time.

1 Like

Got another issue - it all worked fine with an existing Cura GU10 bulb :slight_smile:
I bought another bulb - Accio Mood GU10 - that works differently (different HSV values) but it works :slight_smile:
I've also bought a couple of mains plugs (labelled ConnectBeat) - I can control them using the SmartLife Air app and they appear as devices but computer says I can't control them :frowning:


I find it useful to load the recommended app, then backtrack the resulting configuration, sometimes it is just a matter of firmware version is different that causes differences between the various API layers. I had a couple of smart plugs that seemed to not want to play nice, but after a firmware download the TUYA API saw them just fine.

The app says there's no firmware update available for these devices :frowning: