Project and remote repository issue

I am just implementing projects and using a remote repository is not working for me. I created the repository on github and entered the URL in the project settings. When I do the commit I am not asked for any credentials and when I review the commit history it says "remote: none"

The config file in the .git directory looks good to me. Here it is. The *s are where my userid is

[core]
        repositoryformatversion = 0
        filemode = true
        bare = false
        logallrefupdates = true
[remote "origin"]
        url = https://github.com/*********/home-control.git
        fetch = +refs/heads/*:refs/remotes/origin/*

When you do a commit, you are creating that commit in your local repository. It doesn't get automatically pushed to the remote repo.

The reason it says remote: note is because it doesn't know what remote branch it should be tracking.

I wrote up some instructions for adding a remote and pushing to it for a recent workshop. Have a look through this and see if it helps: https://knolleary.net/node-red-workshop-photobooth/part4/one-more-thing.html

I also wanted to mention, In the project instructions here:

https://nodered.org/docs/user-guide/projects/

It states to enter the project enabling text into the settings.js file. I did this and it didn't work. I then realized that the text was already in there and I needed to change the "enabled" to true. You may wish to change the docs.

I think I almost have it nailed.

I was able to the initial push to github. And I was able to pull the project to another NR setup. It worked great!

But, when I made changes to the master NR it did not sync up with github. I am getting an "unable to access remote repository" error. The only things that changed between the original push and the second push attempt is the pull to the other NR instance and I moved a node on one of the flows just to generate a change I could deploy.

I found the problem. On github I created a private repository. So the token would not work as it was defined for public access only. I created another token for private access and it worked.

1 Like