Node red projects feature

#1

Hi there,
As I use node red within quite a couple of devices already I’m looking for a good guide, how to setup node-red projects, with github.
And somehow my regular info source YouTube let me down on this. However, does anyone have a good tutorial, how to setup the feature from scratch?

Thanks in advance
Philipp

0 Likes

#2

Some good info (including a video) via the blog - https://nodered.org/blog/2018/01/31/version-0-18-released

1 Like

#3

Thanks for the link, I’ll check it out :slight_smile:
I don’t know, why YouTube did not find that. Probably me typing the wron search request :slight_smile:

0 Likes

#4

Hi Dceejay,

I followed the video. Thanks for the link.
One thing I was missing in the video: how to create a new empty repository with node red flows.
Not cloning a repository but how to start from scratch.

I was able to try and error it out.

basically I made everything the same till the setup of the git remote. For the remote I created a new GitHub repository.
then, when the last “new button” appears according tho the video, (arrow up arrow down button)… when I tried to push the code, it asked me for a branch… I just typed master and whoops, it worked :slight_smile:
maybe this could be part of a how to if you ever do one again, otherwise, if someone else has similar problems here is now the hint :slight_smile:

2 Likes

#5

I am also stuck with the remote part.

Everything works fine. I can create projects, create branches etc. But I don’t see any effect in my Github account when I commit changes to a project.

I’m going to follow the video and try to grasp what you diff, echtelerp. Keep you posted…

0 Likes

#6

I have been struggling around. I really could use some help.

A step-wise description on creating a new project, with a remote would help!

As I don’t have existing repositories with nodered flows cloning does not work for me.

0 Likes

#7

Hi Goofy2k,

Where did you get stuck?
did you create an empty GitHub repository?

0 Likes

#8

Hi, thanks for your reply.

I created an empty repository and copied the SSH related URL into the Git remotes field in the NR Project>Settings tab.

In the NR Settings > Git config tab I added an SSH key, which I then copied into the Github User settings > SSH and GPG tab. Then, in the Settings > Deploy keys of the empty repository I pressed the Add Deploy Key knob and added the created key.

When I make some changes to my flow I see that flow.json has changed. I can commit the changes locally. When I go to the commit history, I see a knob with Branch: master and a knob with the two arrows. When I press the two arrows a pop-up appears, stating “Your local branch is not currently tracking a remote branch”. When I press on the branch field, I get a red pop up with: " An unexpected error ocurred. “Error: Host key verification failed. fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists.”

Somewhere in the process in creating the SSH key I marked a field that there should be read/write rights.

I tried this over and over, but don’t know how to get on.

0 Likes

#9

In the video a method is described to clone an existing repository. I tried to do this for the example project shown. But then I hit on the problem that I don’t have the passkey for the credentials.

For someone who is new, like me, it would probably be nice if there would be a description of how to start a project from scratch (create a New project), OR, to have an example project with the relevant passkey(s) available for cloning.

0 Likes

#10

Just to add an FYI..

I struggled with this for days until I realized that my Github account has 2FA enabled. This means I should have been using an Access Token instead of my normal github account password. Unfortunately, there was no feedback from the Node-RED editor and it just accepted my regular password and silently fail. It wouldn't sync or display any warnings/errors.

.. but it works now :slight_smile:

0 Likes

#11

I had this same problem and was stumbling around for quite a while until I found your comment and tried that. I suppose I just assumed that once you added your keys and the remote branch details it would know the branch name, but clearly not :slight_smile:

The one other thing that got me into trouble is the ssh link you copy from github starts with git@, however the dialog in the add remote section suggests prefixing it with ssh://, which I did of course, but it doesn't actually want that at all :slight_smile:

0 Likes