Protobuf decode into JSON

Hello Community,
I am trying to decode proto formatted data I receive from rabbitmq. I am using node-red-contrib-protobuf node. I have tried the other available nodes as well but none of them seem to be working.
With this one, the error I get is :
"No .proto types loaded! Check that the file exists and that node-red has permission to access it."
And an error on the node is "Protofile not ready"
The reason could be that i haven't provided the proto file path correctly. This is how I specified the path:
Path: /C:/Users/S_SB/.node-red/call.proto

And the type is correct.
Also, I can see the data in the proto format in the output when I don't use decoder so the data is coming through but fails to decode.
Any idea, what the reason(s) might be and if the path is in the correct format?
Any help would be appreciated.
Thank you!

I would try without the initial / ie just C:/Users/S_SB/.node-red/call.proto

1 Like

Hi @dceejay
Thank you for your reply. I tried that with the other node and it wasn't able to read the file. With the current node, there is no error in the debug console but the error on the node "Protofile not ready" still exists. Node red is not able to access the file somehow. Even though I changed the file location to node red installation folder. Any idea how I can make it working?