Question characters in my buttons

#1

I have imported my flow into a new node red environment and all of a sudden I have question characters in my buttons. I also suddenly have my group title linked to my dashboard title.

image
image
image

0 Likes

#2

Different system regional & language settings on machines?

0 Likes

#3

I do indeed have one machine on Dutch and the other on English. What is the solution for this.

0 Likes

#4

I've seen it once and then I fixed all strings manually. There wasn't too many of them so it was reasonable to do. Don't know if there is any simple workaround.

Might be different dashboard versions?

0 Likes

#5

Okay the problems are in the used strings. But is that also the explanation for merging the titles?

0 Likes

#6

Dashboard version are the same. But I work with node red version v0.19.4 and v0.19.6 can there be a problem?

0 Likes

#7

For me as the default user it's hard to tell. The evolution of Node-Red has been quite rapid lately so it might be. Real answer needs deep analyse of guys with core level knowledge. .

0 Likes

#8

Thank you. Maybe one of these guys has a solution. I'll wait a while. Is it easy to change version if you want to go back.

0 Likes

#9

Problems with question marks have indeed been resolved. I had worked with "xxx" instead of "xxx".

msg7 = {"Label": global.get("Save")||0};

msg7 = {"Label": global.get('Save')||0};

I will just check my code for more of these problems.

0 Likes

#10

With this adjustment of the string, the merging of the titles is also solved. Very strange.
So problem solved, case closed

0 Likes