Raspberry: No Sound in Browser-Dashboard

I try to get a sound-output if a message arrives.
But it is not possible to hear a sound.
I can see (in workflow) that sound is loading but I can't hear it.
I used the "sound out" node.
Maybe somebody can give me a working example?
Thanks a lot for your help

  1. What device is Node-RED running on?
  2. What version of NR and node.js are you running? (you can get this from the startup log)
  3. What is the full name of the 'sound-output' you are using? It will be something like node-red-????? You can find this by accessing the 'Manage palette' option in the editor.
  4. Are you using HomeAssistant or running in a Docker image?
  5. can you create a small flow that demonstrates the issue? If so, please export it and attach it to a reply.

It would also help to know what browser you are using and what device it is running on.

Ok, I will try to answer your questions
I don't know why you need that for an example .. but...
Node-Red is running on a raspi
node-version is 16
node is: dashboard sound out" (I wrote on top text)
no docker, no home assist
"audio out" note has nothing to select in "TTS voice"
If I start the output with text input - I see the text in my browser-dashboard
but I do not hear nothing.
I use Win11 with FireFox to open the raspi-page :1880/ui
I have two nodered books....and web pages ... all say that should work...
but is does not....mybe I have to install a voice-package I don't have on
my raspi ???
Anything else that cat help you to help me?
Thanks a lot
ps: sorry for my english I'm german

Hallo @paule !
Willkommen hier im Forum.

Dann versuche ich doch mal, mit in diesen Austausch einzusteigen.
Vielleicht kann ich ja ergänzend helfen:

Kannst Du einen flow hier posten, der das Problem zeigt? Falls ja, ...

... bitte so formatieren (Button </> im Editor hier)

... damit man das besser lesen und verarbeiten kann.

Wenn Du spezielle Nodes verwendest, ist es immer hilfreich, diese eindeutig zu benennen & am Besten einen Link auf ein Repository anzugeben ... ansonsten läßt Du viele Menschen hier Zeit für Herumraten ver(sch)wenden.

Please try the attached flow and see if you get some sound. There are two audio nodes and this flow uses both the node-red-dashboard audio out node and 'node-red-contrib-play-audio'.

I discovered an interesting thing. I'm running NR on Pi 4 Model B Rev 1.2 but I am accessing the editor and dashboard on my Mac using Safar. I chose the TTS Voice: 30: Fred (en-US) -- DEFAULT and it works fine. I then opened a Firefox browser and connected to the dashboard. When I press the button to trigger the sound, I get two different voices saying the expression, the one I chose (a male voice) and a second voice from FireFox, a female voice.

It turns out that on my Mac, I had that female voice selected in my Mac system settings. So there are multiple possible conflicts, overrides that might be happening.

================ (translation by Google)

Bitte versuchen Sie den beigefügten Fluss und sehen Sie, ob Sie etwas Ton bekommen. Es gibt zwei Audio-Knoten und dieser Ablauf verwendet sowohl den „Audio out“-Knoten „node-red-dashboard“ als auch „node-red-contrib-play-audio“.

Ich habe eine interessante Sache entdeckt. Ich verwende NR auf Pi 4 Model B Rev 1.2, aber ich greife mit Safar auf den Editor und das Dashboard auf meinem Mac zu. Ich habe die TTS-Voice ausgewählt: 30: Fred (en-US) -- DEFAULT und es funktioniert gut. Ich habe dann einen Firefox-Browser geöffnet und mich mit dem Dashboard verbunden. Wenn ich die Taste drücke, um den Ton auszulösen, erhalte ich zwei verschiedene Stimmen, die den Ausdruck sagen, die von mir gewählte (eine männliche Stimme) und eine zweite Stimme von FireFox, eine weibliche Stimme.

Es stellt sich heraus, dass ich auf meinem Mac diese weibliche Stimme in meinen Mac-Systemeinstellungen ausgewählt hatte. Es gibt also mehrere mögliche Konflikte, Überschreibungen, die auftreten können.
Oh mein Paule! es schneit

[{"id":"0c3d5b609fd1f9c2","type":"tab","label":"Flow 2","disabled":false,"info":"","env":[]},{"id":"6c564c14d777631a","type":"ui_button","z":"0c3d5b609fd1f9c2","name":"","group":"e8cd11232523a0b4","order":1,"width":0,"height":0,"passthru":false,"label":"button","tooltip":"","color":"","bgcolor":"","className":"","icon":"","payload":"","payloadType":"str","topic":"topic","topicType":"msg","x":270,"y":120,"wires":[["57e084b6b749fe8f"]]},{"id":"57e084b6b749fe8f","type":"change","z":"0c3d5b609fd1f9c2","name":"","rules":[{"t":"set","p":"payload","pt":"msg","to":"hello paule","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":520,"y":120,"wires":[["9198161c55b9d67d"]]},{"id":"147c1b326550e22f","type":"inject","z":"0c3d5b609fd1f9c2","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":280,"y":220,"wires":[["cf6ea38d819a0847"]]},{"id":"cf6ea38d819a0847","type":"change","z":"0c3d5b609fd1f9c2","name":"","rules":[{"t":"set","p":"payload","pt":"msg","to":"Oh mein Paule! es schneit","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":520,"y":220,"wires":[["9198161c55b9d67d"]]},{"id":"dcac24d59d984b07","type":"ui_audio","z":"0c3d5b609fd1f9c2","name":"","group":"e8cd11232523a0b4","voice":"com.apple.speech.synthesis.voice.Kathy","always":false,"x":780,"y":380,"wires":[]},{"id":"9198161c55b9d67d","type":"play audio","z":"0c3d5b609fd1f9c2","name":"","voice":"43","x":770,"y":180,"wires":[]},{"id":"781ed7f1e292d64e","type":"ui_button","z":"0c3d5b609fd1f9c2","name":"","group":"e8cd11232523a0b4","order":1,"width":0,"height":0,"passthru":false,"label":"button","tooltip":"","color":"","bgcolor":"","className":"","icon":"","payload":"","payloadType":"str","topic":"topic","topicType":"msg","x":250,"y":320,"wires":[["38d6f34b5db602fe"]]},{"id":"38d6f34b5db602fe","type":"change","z":"0c3d5b609fd1f9c2","name":"","rules":[{"t":"set","p":"payload","pt":"msg","to":"hello paule","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":500,"y":320,"wires":[["dcac24d59d984b07"]]},{"id":"49fa7447ed296e5b","type":"inject","z":"0c3d5b609fd1f9c2","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"","payloadType":"date","x":260,"y":420,"wires":[["8650faa6c462a8aa"]]},{"id":"8650faa6c462a8aa","type":"change","z":"0c3d5b609fd1f9c2","name":"","rules":[{"t":"set","p":"payload","pt":"msg","to":"Oh mein Paule! es schneit","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":500,"y":420,"wires":[["dcac24d59d984b07"]]},{"id":"e8cd11232523a0b4","type":"ui_group","name":"Default","tab":"0d5b5590fa51de78","order":1,"disp":true,"width":"6","collapse":false,"className":""},{"id":"0d5b5590fa51de78","type":"ui_tab","name":"Home","icon":"dashboard","order":1,"disabled":false,"hidden":false}]

Just to confirm this works in FF on my WIN11 PC.

This doesn't seem like the node is installed/working correctly then ?

I can confirm that on the dashboard AUDIO node does not play sound either TTS or otherwise on an iPhone 6, but works on Android and PC.

1 Like

I think is due to limitations imposed by the Safari browser - no autoplay etc.

Thanks zenofmud,
and all the other who helped me.
I tried your example....but with the same result.

  • NO Sound Output -
    only a text messge on my FireFox-Dashboard-Window.
    and there is nothing to select in both sound-nodes.
    So I can't select a TTS-Voice in my dashboard "audio out" node.
    ..my book thays that should work, even if I don't select anything....
    so, I think I have to install something on my Raspi-4 to get it working.
    Maybe I have to upgrade to node-version 18 ????
    By the way I tried TTS on my Win11 (system settings) and it worked.
    Maybe one day....

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.