Rasperry Pi 4 Serial port RX issue

I've been successfully using NODE-RED for a few weeks now on my laptop. It was decided we want to use a Raspberry Pi as our NODE-RED platform so I bought a Pi4 and IO board. I've started by enabling the mini-UART and using a terminal emulator (CuteCom) wired to the laptop running Tera Term. I could get TX (Pi to Laptop) fine but no RX (Laptop to Pi). I then disabled the BT so I could use UART1. I now have full duplex communication using CuteCom to Tera Term.

Next I loaded Node-Red and made a simple simple serial port flow with an inject node connected to the serial out and diag node to serial in. I again can only get TX functionality of Node-Red to Tera Term.

I also have a Raspberry PI3. I did all the same steps with the same result. What could I be doing wrong here?

I enabled UART2 on my PI4. Again I can send and receive using terminal emulators but cannot receive using NODE-RED. Any suggestions are welcome!!

I tried using the serial request node and it seems to work. Only the serial in node not working. I may be able to make the request node work for my application but it will create more work. I am still hopeful that someone can help me out.

I have solved my issues, no need to comment.
With UART2 I just needed to adjust the timeout then everything worked.

I use the uart1 often. It works for me when i disable the serial console in the interface setup.
schnittstellen setup

Thank you for your reply.
Now that I have UART2 working, I've moved on. Hopefully i won't run into this issue again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.