[Resolved] Cannot find Arduino port in Serial In or Serial Out nodes

Hello, I am extremely new to Node Red, so I apologize if this is a simple question, but I cannot seem to be able to connect my Arduino to the Serial In or Out nodes.
I am using the browser version of node red, and my Arduino is on COM1. However, when I enter COM1 in the serial node settings, I get the error: "serial port COM1 error: Error: Error: No such file or directory, cannot open COM1"
Here are my node settings:


It all matches my COM1 settings, but it won't recognize it...Any help is truly appreciated!

What is the O/S you are using?

I'll leave it there as the next question really depends on your reply.

1 Like

I am running a Windows 10 Home, version 1909 and 64-bit type

Does anything else have com 1 open? Is com 1 in device manager?

1 Like

It is in device manager as USB Serial Device, yes, and it is only connected to the Arduino itself but I made sure that the serial monitor is closed before running Node Red

Could it be still hanging onto the port.

A sure fire way is to reboot PC & try again.

Failing that, perhaps there was an issue compiling the serial port code for Windows 10 when you installed node-red or a node that installs serial?

Did / do you have windows-build-tools installed?

npm install --global windows-build-tools

if not - then you might need to install that then install serial port again

see this similar thread Error while lauching Node-Red: "It looks like serialport didn't compile properly. This is a common problem and its fix is well documented here https://github.com/voodootikigod/node-serialport#to-install"

1 Like

Can you explain what you mean by that? How did you install node-red?

1 Like

I tried this but nothing changed, so I guess this is not the issue.

I didn't remember installing this, so I tried to run this command, but I got an error saying it doesn't recognize npm? I googled the error and found that I need to download NodeJS first, so I went ahead and tried and now the command works, but unfortunately It still doesn't recognize my port.

You mean to reinstall the serial port node, right? I did that after the previous step but still no luck :broken_heart:

Last night, I tried to install and run Node Red locally from the command line after trying all of this, and the node is working there perfectly, but it is still not working if I launch it from the Ibm cloud site. I would really like to be able to use the cloud site as I am using many IBM services in my flows, and I also feel it is easier for my teammates to log into the website and see the same space I have instead of asking them to import the flows every time I make changes.

Oh, I am sorry for being unclear, I meant that I am using the IBM cloud version like this: https://nodered.org/docs/getting-started/ibmcloud

You can't use the serial port on the cloud version as the cloud server doesn't have a serial port (at least not one you can use, since it is the other side of the world, possibly).

1 Like

Oh!! That's unfortunate for my case, but it does make sense, thank you so much for letting me know!

:man_facepalming:

but but but you were talking about Windows and COM1 etc etc

note to self - ask more questions before helping!

I think there was confusion about the concept of where node red runs when you use the cloud version, thinking that in some way it was running in the browser and could access the com port on the PC.

Yeah, I've seen folk tripped up by this concept many times & should have thought to ask - doh.

Yess, this was it, I think my brain didn't make the connection at all; since I saw that the microphone node could hear me, I thought the serial node would somehow work in the same way. I am so sorry for the confusion @Steve-Mcl I should have known better, thank you for trying to help though!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.