Restoring files from desktop NR and electron

Hi, for the past few weeks I've been making a dashboard on NR. It worked great.
but then I want to be able to distribute the project. I followed the tutorial I found on making it as a desktop app. which leads me to electron. It didn't work.
I then looked up some more information on this topic and found something similar but it has a setup.exe file and source code. I ran the setup and it gave me an empty node-red editor window. cool. I played with it a bit by placing some hello world text_ui node and closed the window.
Later when I tried to open my dashboard project with my cmd like I used too. To my suprise I found out that instead of my dashboard, it gave me the hello world text_ui. also my editor gave me "Cannot GET /" message.
Luckily I made a copy of flows_xxx.json and flows_xxx_cred.json yesterday so I tried replacing the files in ~.node-red with my backup. Nothing happens. It still is the hello world text_ui. Looking at my cmd, the files that are used are in the right directories.
Any suggestion on how to restore my project? also this is my first time doing a web-related programming so a more detailed explanation will be greatly appreciated.

Hi Ivy, welcome to the forum.

It sounds as if node-red is picking up the wrong flows file. If you start node-red in a terminal you will see the startup messages and in there will be the flow file is is using.
Tell us which operating system you are using as that will make it easier to help.
If you can't work it out then copy/paste the startup log here (it should start with a Welcome to node red message).

Thank you for the reply. Just now I manage to solve the problem by restarting my computer. It worked just as before now