RFXtrx node not working on one Pi after upgrade

I did the regular upgrade process that I always use on two identical Pis:

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

But on one of them I updated Python as well, to 20.1.1. with:

sudo pip install --upgrade pip

That seems to have broken Node-red-contrib-rfxcom, it's stuck on the same stuff as in this thread:

But the commands at the bottom there are not working for me, probably because that's another Linux distro (I am hopeless with Linux, I can follow instructions but mess up roally if I try to do anything outside of that). Can I revert to a version of Python that's supported by the node, or is there something else I can do?

Hey Mastiff,
You must have received a far future pre-release, Python does not have that versioning numbers (yet). Maybe sometime 2099....

Hi, Walter! :slight_smile: Nice to see you! And you're quick... I edited my post. So it's probably not the version, but I get this:

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: pip in /usr/local/lib/python3.5/dist-packages (20.1.1)

Hi there,
I think that just tells you that you have pip version 20.1.1. Pip is used for installing python packages and I don't think that has anything to do with the RFXtrx part. I think instead it might be that you have problem with the serial port? Could that be the case? Once happened to me long time ago, I fixed it by running the upgrade/install script one more time

I see! :wink: Thats why the version was so strange. According to the post I linked to above it needed the correct version of Python to work. But I have now tried the script again, and it still says "Waiting for the missing types to be registered". Luckily this isn't the most critical Pi in the house, so I can leave it like this until tomorrow at least.

Oh, I see that Pi's still on Stretch... I must have forgotten to upgrade it to Buster last fall, when I thought I did them all. I'll do that and see if that doesn't help. :blush:

I think that Python is used to help compile some C dependencies? Certainly not needed by the RFX node itself.

Watch out for Python version changes though since Python 2.x is no longer supported and depending on how you have things set up, you might need to use pip3 rather than pip to update Python dependencies.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.