Riot-nodes error

Just to confirm, does this mean you do now have the riot nodes in your palette?

If you have questions about how to use those nodes, you'll have to direct them to the author of the module.

This is what i've got. Should i ''enable all''

Martin, must you use that particular node - considering it is about 5y old.

Have you tried node-red-contrib-xbee (node) - Node-RED?

@Martin10 there is a huge error message there.

That error would have been logged when Node-RED started.

So when you said NR work good (no errors), - were you ignoring those errors?

I tried to use this example (xBee transmit and recieve (flow) - Node-RED), but I can't send a message through it, not to mention sensor data (i please for help here, but nothing). Also this example only uses a transmit/ receive type of connection and the riot project says it uses a mesh network (i hope).

In NR i have this

Welcome to Node-RED
===================
12 Jul 15:02:09 - [info] Node-RED version: v1.3.5
12 Jul 15:02:09 - [info] Node.js  version: v12.18.4
12 Jul 15:02:09 - [info] Linux 5.4.51-v7l+ arm LE
12 Jul 15:02:09 - [info] Loading palette nodes
12 Jul 15:02:27 - [info] Dashboard up and running
12 Jul 15:02:32 - [info] Dashboard version 2.20.0 started at /ui
12 Jul 15:02:33 - [warn] ------------------------------------------------------
12 Jul 15:02:33 - [warn] [node-red-contrib-usb/adkinit] SyntaxError: Invalid or unexpected token (line:59)
12 Jul 15:02:33 - [warn] [node-red-qnap-blockly/blockly] Type already registered
12 Jul 15:02:33 - [warn] [riot-xbee/riot-xbee] Error: Cannot find module '/home/pi/.node-red/node_modules/riot-xbee/riot-xbee.js'
Require stack:
- /usr/lib/node_modules/node-red/node_modules/@node-red/registry/lib/loader.js
- /usr/lib/node_modules/node-red/node_modules/@node-red/registry/lib/index.js
- /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/index.js
- /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/index.js
- /usr/lib/node_modules/node-red/lib/red.js
- /usr/lib/node_modules/node-red/red.js
12 Jul 15:02:33 - [warn] ------------------------------------------------------
12 Jul 15:02:33 - [info] Settings file  : /home/pi/.node-red/settings.js
12 Jul 15:02:33 - [info] Context store  : 'default' [module=memory]
12 Jul 15:02:33 - [info] User directory : /home/pi/.node-red
12 Jul 15:02:33 - [warn] Projects disabled : editorTheme.projects.enabled=false
12 Jul 15:02:33 - [info] Flows file     : /home/pi/.node-red/flows_raspberrypi.json
12 Jul 15:02:33 - [info] Server now running at http://127.0.0.1:1880/
12 Jul 15:02:33 - [warn]
---------------------------------------------------------------------
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
---------------------------------------------------------------------
12 Jul 15:02:33 - [info] Starting flows
12 Jul 15:02:33 - [info] Started flows

So there is still an error with the riot nodes.

I have tried looking at their source code on github, but the code there is for version 0.0.1 - but the latest published version is 0.0.6.

To be frank - we cannot keep spending our time on this. The Riot nodes have not been updated for years. They are broken. We have done what we can get past the generic install issues, but clearly the issues run deep here.

I strongly suggest you stop trying to make the riot nodes work.

As Steve has suggested, there are other xbee nodes available. You may have more luck with them.

I tried to use this example (xBee transmit and recieve (flow) - Node-RED), but I can't send a message through it, not to mention sensor data (i please for help here, but nothing).

That example flow appears to be using node-red-contrib-xbee (node) - Node-RED

It has nothing to do with the riot-xbee module.

I don't know what else to say. Have you got node-red-contrib-xbee installed?

Yes, i install anything for this flow. i have topic in this forum for this flow with pics.

There is an example towards the bottom of the readme

I imagine you need to set id, destination64 and destination16 to something that matches your setup.

As we have said, we dont use xbee and your other threads got no answers - the only thing we can suggest is raise a new issue asking the author for assistance.

I fulfilled every requirement. I send several questions, but no help.

You did not raise an issue on the github repo.

Yes, i'm. It is in ''closed'' section

So I see

He asked On 25th November...

Could you try this? If all of this looks correct, then it may be a
configuration thing to check with the NodeRed nodes, specifically the
configuration nodes where you specify the COM port, etc for the RX and TX
nodes.

Also you may need to send a command to the XBee to enable reading the
sensor, or it can be configured to make it automatically. But with the XCTU
you may check that.

then on 30th Nov ...

Closing for now, feel free to reopen if you find an issue with the library

  • You didnt re-open the issue
  • You also didnt answer his questions.
  • You didnt reply until 21st Jan

You could try re-opening with more details.


Lastly, you are now running this on a PI. On 24th he said "Check the connections between your XBee and GPIO on your Raspberry" and you replied "I don't use RPI i connect it directly to PC"

But now you are on an RPi - have you tried again?

I answered:

I try this, but in the video not all configs are visible, so i could't repeat them. Can anyone please help me?
Creating a Node-RED MySQL Connection and writing JSON from XBee - YouTube

I have some problems with usb connections on RPI, On PC i can use XCTU for check.

Also, i try in this:

Martin, no one on the forum has replied to your other messages. It is possible no one knows the answers or the right people haven't seen your posts.

I can only recommend you follow this up with the issue you raised.

Also, you didn't answer :point_up:

I have some problems with usb connections on RPI. And those nodes require Com ports

Hi, I came across this topic (Node-Red and Xbee S2C), I noticed that they use this (GitHub - angryelectron/xbmq-java: XBee / Mqtt Gateway
GitHub - angryelectron/xbmq-js: NodeJS XBee to MQTT Gateway) and this (XBee · PyPI). So, is this the best ''formula'' for establishing Xbee connection in NR?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.