Rpi-keyboard node - observations

A while back I was asking how to detect key presses on a keyboard and was pointed to the node-red-node-pi-gpio set of nodes with a keyboard node.

Ok, done.

(This is a side-project and so wasn't receiving correct priority and thus it has taken some time for me to post this.)

I have a couple of keyboards I use mainly. This one on my main machine and one of those rubber "roll up" keyboards.

Both work in so far they allow me to write programs and make mistakes on the machine into which they are plugged.

So, I installed the set of nodes and a few weeks passed until I again needed that functionality.

It didn't work. :frowning:

On the machine the node shows green and all is ok. So what is wrong?
(Beats me)

Today I remembered and so powered up that machine and got another keyboard and plugged it in.

Now it works with that (new/other/never before tried) keyboard.

WEIRD!

I then unplugged this keyboard and plugged it into the Pie. (Two keyboards) (Wow!)

One, works. Other doesn't. (And the third one also doesn't)

All USB keyboards.

The one which works is a Jite brand. (Shrug)
This one (the main one I use for most of my stuff) is a Logitech one. (K120)
and the rubber one.. No-name/brand generic.

Is this to be expected?

Oh, that machine's specs:
RasPi 3B Stretch.
NR 1.2.7
rpi-keyboard 1.2.3 (rpi-gpio)

Anyone?

the node only works with one keyboard - usually the first one it detects. Do you have all three plugged in at once ?
can you show us what ls /dev/input/by-path/ | grep -m 1 'kbd'reports ?

I'll try to get that for you soon.

To clarify:

rubber keyboard plugged in and the node shows a green dot under it.
"All good" - I'm guessing. I even think it says OK.

debug node connected, deployed but nothing when keys pressed.

Hmmm.. :thinking:

Brought the machine back and used this keyboard instead. rubber keyboard not connected.

Same. :thinking: :unamused:

Moved to low priority.

Today I remembered and powered up the machine.

Plugged in entirely new keyboard. Pressed keys. It works!

I plugged this one back in - ok, with other one still in - no result.

But anyway, that's (I hope) a better explanation of what happens.

Oh:

If I swap keyboards, what do I have to do to get the new one to be accepted?

Right, with the working keyboard, this is what I see:

pi@BeefPi:~ $ ls /dev/input/by-path/ | grep -m 1 'kbd'
platform-3f980000.usb-usb-0:1.3:1.0-event-kbd
pi@BeefPi:~ $ 

Pressing keys nothing happens.

Shall reboot the machine and plug in this keyboard first and get back to you.

ARGH!

Ok, now it is working.

I won't be able to test it with the rubber keyboard for a few weeks. (It is in a remote location, and I'm not)