Running node-RED as root

Hi All,

I want to run Node RED as root (only using this in my local network) on my raspberry pi so that I can use 'node-red-contrib-amazon-echo' so I need to allow access to port 80.
If I 'sudo su node-red start', I get "Waiting for missing types to be registered:" so none of the nodes will work.
as a newbie I am obviously missing something.. can someone point me in the right direction?
Is there an easy way to enable access to port 80?

Thanks :slight_smile:

Have a look at this link... (I run Amazon Echo on port 8980 as a NORMAL Pi user).

Not certain you absolutely need root.

See this

Thanks dynamicdave.. I now have my Echo online at 8980. Cant discover my amazon-echo-device yet so I'll go back and look at the setting. I think I am a step closer though. Thanks for your help :slight_smile:

Try creating a new device with the node and then asking Alexa to "discover devices" and see if it is found.

I've just tried my set-up and it's working fine (as there was 'talk' that after the last update by Amazon things had stopped working).

Good luck.

1 Like

There is another way to allow Node-RED to use port 80 without running as root and that is to run it as a service from systemd. This is how web servers work.

1 Like

An update:

Thanks everyone for their comments. I tried the suggestions here but unfortunately (perhaps due to a lack of knowledge on my part) was only able to get Echo to detect my new devices with node-RED running as root. But now it all works so I am happy :slight_smile: I had to uninstall and re-install all the nodes which were coming up with 'Waiting for missing node types to be registered'. So in case it may help anyone else, I thought I would post the update.
Thanks for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.