Save inject interval time (resetting everytime)

So I have this inject node, injecting every 12 minutes with Home Assistant node red addon. The only thing is it has to keep injecting every 12 minutes and should not be any longer or shorter, even after a reboot it should know when it should inject again. So I want the node to remember when to inject. How can I do that?

I think setting it to "interval between times" mode should do it - as that then uses an underlying cron library so every 12 mins will fit nicely into an hour

1 Like

You mean like so?

[{"id":"489fd6b740a238eb","type":"time-inject","z":"84cbaa7d.278f2","name":"Slaapkamer voor","nameInt":"0:00 - 23:59 = $!{lblInject}! ↻12min","positionConfig":"f1f00fcf.fb20b","props":[],"injectTypeSelect":"interval-time","intervalCount":"12","intervalCountType":"num","intervalCountMultiplier":60000,"time":"0:00","timeType":"entered","offset":0,"offsetType":"none","offsetMultiplier":60000,"timeEnd":"23:59","timeEndType":"entered","timeEndOffset":0,"timeEndOffsetType":"num","timeEndOffsetMultiplier":60000,"timeDays":"*","timeOnlyOddDays":false,"timeOnlyEvenDays":false,"timeOnlyOddWeeks":false,"timeOnlyEvenWeeks":false,"timeMonths":"*","timedatestart":"","timedateend":"","property":"","propertyType":"none","propertyCompare":"true","propertyThreshold":"","propertyThresholdType":"num","timeAlt":"","timeAltType":"entered","timeAltDays":"*","timeAltOnlyOddDays":true,"timeAltOnlyEvenDays":true,"timeAltOnlyOddWeeks":false,"timeAltOnlyEvenWeeks":false,"timeAltMonths":"*","timeAltOffset":0,"timeAltOffsetType":"none","timeAltOffsetMultiplier":60000,"once":false,"onceDelay":"3","recalcTime":2,"x":100,"y":560,"wires":[["7d459682c897865e"]]},{"id":"f1f00fcf.fb20b","type":"position-config","name":"","isValide":"true","longitude":"0","latitude":"0","angleType":"deg","timeZoneOffset":"99","timeZoneDST":"0","stateTimeFormat":"3","stateDateFormat":"12","contextStore":""}]

err - no idea - that uses non core nodes.. I mean just the setting in the inject node

Ah thanks I was using the wrong inject node (enhanced) this is working perfect!