Serial Port does not receive data on Rpi5

I have been using the serial port through a docker container using a RPI 3.
I followed the instructions at Docker NR & ttyUSB0 Permission denied - #17 by janvda
I use the node-red-node-serialport node to do this.
Connecting using the GPIO pins.
On RPI 3, it is connecting on /dev/ttyS0 and everything is working fine.

I have recently started upgrading to RPI 5.
But the same method does not work for some reason.
I already changed the port to /dev/ttyAMA0.
On the node, I can see it says connected and the icon shows green. But when I send data through the serial port, no data is received.
But when I test using the command screen /dev/ttyAMA0, I can see the data coming in.
I know that RPI5 has changed how the GPIO works and nodes like pigpio is now broken. I am wondering if the Serial Port has the same issues.

Has anyone else had issues or success in using the Serial port on RPI5 through a docker container?

Hi all,

Today I just tried to get rid of the docker container and just installed node-red directly on the RPI5.
Created the most simple flow with 1 serial in to a debug node.

Same thing. I see that it is connected. But no data comes in.

Tried with screen /dev/ttyAMA0 on the terminal and I can see data coming in.

The funny thing is that while node-red is running and so called connected to /dev/ttyAMA0, the terminal that is running the screen command can still connect to the same serial port. Correct me if I am wrong, but from my understanding, the serial port should be only open to one app am I right?