Serial port fetching data

I am able to read the data of my device in windows system through serial request but I am not able to read the data from ubuntu serial port....
Can anybody try to help me out?

Probably yes, but obviously not unless you give us more information about how you are trying to do it and what result you are seeing. As far as I know no-one here is telepathic.

I have an RS-485 parking sensor through which I have to read the data from dell gateway through RS-485 port itself

So for testing I had converted RS-485 to USB then connected to my PC then through the below flow i fetched the data of it

Then with same I had tried on my Gateway through using both the ports(RS-485 and USB) data is not able receive us.

Try recovering data without using Node-RED to see if it is a serial port issue or a Node-RED issue.

I have tried it is serial port issue, this is node-red forum but too I am raising a question here because I had got most of the solutions here itself.
Can you please help me out with this?

Test with PUTTY if you serial port is working in Ubuntu, if that is working then the next step is NR.

check that the user has permission to use the serial port

It is opening the port but data it is not receiving

@edje11 just have a look on this above screenshot