Simple question for you guys/girls; brain twister for me

(Intro: I'm new to NR; am planning to use Node Red on my sailing boat; Have raspi with Openplotter; and now I need to know my fuel en de weather).

Here we go

Have Arduino with simple sketch with digital barometer (BMP280). I run the sketch and get the values via PrintScreen
Then I initiate NR and have tried to re-build this (https://iotdesignpro.com/projects/interface-arduino-with-node-red-to-send-sensor-data-on-webpage)

Once I deploy I see in Terminal this error message:


3 Dec 20:15:48 - [info] Starting flows

3 Dec 20:15:48 - [error] [arduino-board:9e7b5947.04f23] TypeError: Cannot read property 'on' of null

3 Dec 20:15:48 - [error] [arduino-board:2dca7ade.ce7e9e] TypeError: Cannot read property 'on' of null

3 Dec 20:15:48 - [error] [arduino-board:c0891553.e024a] TypeError: Cannot read property 'on' of null

3 Dec 20:15:48 - [info] Started flows

3 Dec 20:15:48 - [error] [arduino-board:d5e83eb0.89bdd8] port not found : /dev/tty.usbmodem143301

3 Dec 20:15:48 - [error] serial port /dev/tty.usbmodem143301 error: Error: Error: Resource busy, cannot open /dev/tty.usbmodem143301```

So it does not work (obviously)

My questions:

1. I have been able to build the Blink flow and trigger a blink via NR (so my cables are ok ... ;)
2. Why does the port keep giving data to the PrintScreen (Arduino) but stops giving it to NR?
3. What did I miss or do wrong?

Thanks from a sailor.

Bart
1 Like

Small extra thing. I ran the Sketch and then closed Arduino IDE to free up the Serial port

Ok solved it myself. I rebooted Node-Red. Thanks anyway

Bart,

Another idea you could do, if you have WiFi on the boat, would be get a WeMos D1 and install ESPEasy on it. It already has the code for using a BMP280 senson and many more. Set it up to send the data via MQTT to Node-RED on the Pi. You'll have to install a Mosquitto broker on the Pi along with NR, but that is a very simple thing to do.

Mr Zenofmud,

Thanks for reply, will dive into it!
Best,
Bart

1 Like

Mr Zenofud,

Did what you suggested with the following result

" ... Hi,

Some facts:

  • Got my hands on ESP8266 D1 mini
  • Understand Arduino a bit but read about ESP Easy, thought it would be easier to connect to Raspi (incl Openplotter) on my boat.
  • Found out how to flash and was able to flash my D1
  • But now I can not find the AP Wifi to finish the configuration (=connect to my home Wifi)
  • ;(

Do not know where to start, as I have re-flashed the card 4 times by now.

Hope anybody (much smarter) can briefly use his brainpower and put me on a "fixit" path.

Thanks,

Bart

Maybe you can help?

google is your friend see https://www.letscontrolit.com/wiki/index.php?title=EasySetup

My best (online) friend !

Problem is that I do not see the initial AP ESP_Easy_0 (prior to 2.0 the AP was named ESP_0) ...

So I can not get to the D1 ...

So I go to my second best (online) friend .... Mr Zenofmud ...

:wink:

Bart

Bart,

I have had this happen a couple of times after the flash of an ESP8266 with ESP Easy. I have found the easiest way is to perform a cold reboot of the device i.e. pull the power rather than hit the reset button.

I have also found on a couple of different boards that there is a button sequence to press within a short period of time of it booting to get it to go to the initial config

I have never had the flashing process completely fail

Craig

I assume you are using the latest ESP Easy release from here...

The release includes 'ESP.Easy.Flasher.exe' an executable for Windows (sorry Paul no version for iOS) which makes flashing a Wemos D1 Mini very easy.
The only problem I've encountered is the entry for the first WiFi network seems to get ignored.
I just put the details for one of my WiFi networks in both the first and second boxes on the form.

The other thing I've found is sometime the newly flashed device appears at 192.168.4.1

Hope you manage to get connected to your device because once you do it will open-up a number of possibilites for you.

Regards, David.

1 Like

Craig,
(Detailed question)

Do you have the D1 powered via USB of computer?

I read that power/quality of USB cable sometimes is an issue.
( I just bought a new Raspi approved power supply)

Bart

Dave,
Tried this as well. But I'm not able to select a BIN file. I can click the button "open folder", then navigate to the bin file, but there is no OK button.
I tried to drag the bin file, but no luck ...
How did you do it?
Bart

This is what my version of ESP Easy Flasher looks like.
You need to 'click' the bin file you want from the drop-down list.


I just select the '.bin' file and then click 'Flash ESP Easy FW' button (bottom-right of screen).

Note:
I've left the WiFi boxes empty for obvious reasons.

I also give all my Wemos devices a fixed IP address (as I have over 40 of them).

1 Like

Dave,
My drop
down box is empty ... that is the strange thing.

So I clicked on Open Folder ... navigated to the BIN file, but then was unable to click "OK" somewhere ...

So strange ...

Bart

That sounds as if the folder labelled 'bin' (in the area where you unzipped ESP Easy) is empty.
Can you check it?
ScreenShot037

1 Like

What version did you download?

1 Like

Dave, I think I got it (via you!) Let me try some more things. Will get back. Best Bart

If the 'bin' folder is empty, you can always drag-n-drop a bin-file into that area as a temporary solution.

If you are using a Wemos D1 Mini, then I would use this bin file.

ESP_Easy_mega-20191130_normal_ESP8266_4M1M

1 Like

Dave,

Yes that is what I did. I "found" the correct bin file and was able to flash the D1
(+gave the Wifi credentials)

After the flash I got the message from Easy flasher that all went well.

I also configured a fixed IP address. 192.168.1.123

But then ... I tried to login via a browser on 192.168.1.123 without any succes.

Via Google WIFI I looked for my newly flashed D! ... no luck

So .. what is the next thing I did wrong ...?

(sorry I keep asking such simple questions)

Bart

Did you fill in your wifi info? If so did you reboot the Wemos after that?
If yes, you should be able to enter the IP address in a browser to get to the ESPeasy configuration.

I can't really help on the Windows side, as I do it on my Mac and have to flash them using a CLI.

Note: doing it the first time is the hardest, so take notes for the next time :smile: