Simple voice messages don't work with google home and Node-red-nora

I have created a flow using nora nodes.
I have created a nora token, that iuse with my gmail account.
I have created some objects (lamp, switch, thermostat,...) in my flow, and I can control them from google home app.
But I can control only with clics on the element. I can not control them by voice.
For example, if is say 'swich on the office lamps', i get a message wich says that the lamps are not yet configured.
But, what is very strange, is when I create a routine in Google assistant.
Here also, I can see all my node-red nora elements.
And if I create a routine 'hello home', and if I define as action to switch on the lamps, the routine works fine.
Did I forget something?

I just wanted to ad some more detail : I use only one account (gmail) and so, google home and google assistant and NORA use the same account.

Sounds like it's on your Google Home side. To confirm, you can see the office lamps in Google Home? Have you tried to use the name of a specific lamp as defined in Google Home vs it sounds like you were trying to turn on a full room of lamps with your example above?


Yes, in Node-red flow, I can see my
lamps. They react correctly when a routine order is sent, but they don't
react if I just say 'turn on the lamp in the office at house'. Alos, they
don't react to a generic command 'turn on all the lights at home'.

They only react to a specific routine
message taht i have defined myself.

No, I'm saying on the Google Home side double check the name, room on a single device and test that. If you can setup routines and they trigger in Node-Red I doubt the issue is on the Node-Red side. I suspect it's something in how your device is configured in Google Home vs. how you are trying to trigger it.

I have exactly the same problem. I migrated from Nora to Smart Nora, and now I can click the icons and control lamps, screens, etcetera without any problem. I can switch everything on and off.
But using voice control (like I did when I used Nora) does not work.
It looks like it is on the Google Home side, but what and where? Any hints?

I have not really solved the problem, but did manage to make it "go away" by simply resetting the Google Mini to factory settings, and re-install it. After that the voice control worked as before...