SNMP OID Not Valid, but Linux CLI snmpwalk disagrees?

So this OID... is choking up snmp node in node red?


Where as linux cli snmpwalk...

# snmpwalk -v 1 -cDD hall
iso. = IpAddress:
iso. = IpAddress:

But via node red snmp node...

"RequestFailedError: NoSuchName:"

Other OIDs I have tried seem to work, such as...

Ok? What gives?

Don't know that I've ever had that much joy with that node and many SNMP responses don't always play nicely with JavaScript either due to being very large numbers.

Personally, I'd use Telegraf to translate SNMP to InfluxDB and MQTT as I use it for other monitoring already.

Telegraf Best Practices: SNMP Plugin | InfluxData

Yeah, unfortunately I have some routers that only support SNMP. But I managed to work round the issue. This is not the first time the 'get' snmp node gripped about a completely valid OID.

There is something a bit funky with that set of nodes, or the code below them. The SNMP walk node for example does not behave like the typical snmpwalk linux CLI command does, but the SNMP walk node does what its documentation states if will do, so go figure.

Where the 'get' node failed, the 'subtree' node worked, for this specific OID. I wish the error reporting was was bit better, just throwing back that a given OID is invalid seems like a catch all returned result? But I suspect that is coming from the code below the nodes.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.