[Solved]: No Layout, Site or Theme tabs on Dashboard sidebar after upgrade

I have been running Node-RED on a RPi 3 for about the past 4 years and just did an upgrade from 0.16.n to the latest and greatest. I used the upgrade script 'update-nodejs-and-nodered' mentioned in the Node-RED doc. Prior to the update I did an image copy of the RPi SD card.

I did see some initial issues after the upgrade, mostly due to the upgraded UI widgets having additional configuration parameters and different defaults. These have been solved through direct examination, reading the various error and warning messages, google searches and just sitting and thinking about some of the behaviours I saw after the upgrade.

The one ongoing problem I am seeing is the dashboard sidebar in the editor is blank. Instead of seeing:
(image borrow from another post)

Instead I am seeing this:
I did check the /var/log/nodered-install.log and did not find and error or warning messages related to the installation/upgrade process.

Likewise, the startup log from node-red-log does not have any warning or error messages:

pi@moode:~/.node-red $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to http://flows.nodered.org

Starting as a systemd service.
Started Node-RED graphical event wiring tool.
21 Jul 12:17:57 - [info]
Welcome to Node-RED
21 Jul 12:17:57 - [info] Node-RED version: v1.1.2
21 Jul 12:17:57 - [info] Node.js  version: v10.21.0
21 Jul 12:17:57 - [info] Linux 4.9.35-v7+ arm LE
21 Jul 12:17:58 - [info] Loading palette nodes
21 Jul 12:18:01 - [info] Dashboard version 2.23.0 started at /ui
21 Jul 12:18:02 - [info] Settings file  : /home/pi/.node-red/settings.js
21 Jul 12:18:02 - [info] Context store  : 'default' [module=memory]
21 Jul 12:18:02 - [info] User directory : /home/pi/.node-red
21 Jul 12:18:02 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
21 Jul 12:18:02 - [info] Flows file     : /home/pi/.node-red/flows_moode.json
21 Jul 12:18:02 - [info] Server now running at
21 Jul 12:18:02 - [warn]
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
21 Jul 12:18:03 - [info] Starting flows
21 Jul 12:18:03 - [info] Started flows
21 Jul 12:18:03 - [info] [mqtt-broker:f20c601c.ee07e8] Connected to broker: mqtt://localhost:1883

Without some useful warning and error messages, I don't know where to look or what to google to trouble-shoot this problem.

Any suggestions would be greatly appreciated to solve this issue.

P.S. I am completely new to Discourse so my composition skills are completely new. I how the images I captured and then pasted into this post are visible. Any suggestions with regards to steps, tips and tricks for posting are also greatly appreciated.


Have you tried to clear the browser cache?

Thanks for the suggestion. One of my first actions. Google is a very good friend of mine!
I have tried some of the more usual tricks:

  • reboot
  • reinstall
  • different browser (Edge, Chrome)

Same result each time, a blank dashboard sidebar.

Not sure what is going on.
Started my laptop after a night of sleep, connected to the Node-RED editor and lo:
I now have the dashboard sidebar populated! :confused:

I am using FireFox as my main browser, so I don't know if shutting down the laptop over night caused the content in the cache to age-out. The curious thing is I also used MS Edge and Chrome to check the sidebar was not populating.

Oh well, chalk one up to the digital gods. :pray:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.